Cloudy noise in 2.8 compared to 2.79


#1

Hi Blenderenderers,

While doing some tests using Rawalanche’s interior test scene from this thread: https://blenderartists.org/t/cycles-performance/1121187

I found out that min bounces has a big impact on “cloudy” noise seen most on white surfaces in interiors… Makes sense…

If min bounces is set to a high number the cloudiness gets much better at the cost of about +20% to render time, however to get the same result with low min bounces (or with no setting in 2.8) we would have to render much more samples than +20%.

This is not possible to set up now in 2.8 and I believe to get the same result we would have to render the scene much longer than in 2.79 with high min bounces.

RMB and open image in new tab to see differences. Not sure what happened to the click to open gallery

2.79
transparent min 10
transparent max 10
max bounce 10
min bounce 6
diffuse 6
glossy 6
transmission 10
volume 0
666_10transpmax-10transpmin_10max-6min_6diff-6glossy-10transm-0vol

2.8
Max bounce 10
Diffuse 6
Glossy 6
Transparent 10
Transmission 10
Volume 0
666_10-6-6-10-10-0

2.8
rendered to match rendertime of 2.79
800_10-6-6-10-10-0


#2

The only way cloudy noise can happen is when using denoiser, which is probably enabled here. In that case, more “cloudiness” just means more noisy input for denoiser to process. It’d make more sense to make the renders with denoiser off and compare the noise levels.


#3

That’s right but another word for cloudy noise could be low frequency noise and it says in the min bounces tooltip that the render will come out faster but noisier. It makes a lot of sense since light rays are being terminated when deemed to have no effect on the image but of course even if the light added is low it adds up if millions of rays are made to go at least 6 bounces before being terminated.

Unfortunately compared to Corona there seems to be noise that never goes away with Cycles (unless ridiculous amount of samples is rendered) which makes me use the denoiser for virtually every interior scene I rendered. So for me it’s more important to see how it looks denoised rather than not denoised. I have to point out now though that setting the min bounces higher helps with this quite a lot. It’s not consistent with the start of this column but I may actually try to render some interiors without the denoiser ^…^

Anyway, here are the renders not denoised. It is very visible now how much noisier it actually was :slight_smile:

You can see bounces at 4 to be quite a bit darker but I found that in most scenes it’s not such an issue as here because most scenes are not completely white. What is more interesting is that it rendered a bit faster than 2.8 while being much cleaner.

Also setting min bounces and diffuse bounces to the same number produces less noisy results.

2.79 min bounces and diffuse bounces both at 4
notdenoised_666_8transpmax-8transpmin_8max-4min_4diff-6glossy-8transm-0vol

2.79 min bounces and diffuse bounces both at 5
notdenoised_666_8transpmax-8transpmin_8max-5min_5diff-6glossy-8transm-0vol

2.79 min bounces and diffuse bounces both at 6
notdenoised_666_10transpmax-10transpmin_10max-6min_6diff-6glossy-10transm-0vol

2.8
notdenoised_666_10-6-6-10-10-0


#4

@brecht Could you please check this out to see if it’s fixable? Thanks!


#5

It’s on my to do list, just not at the top right now.