Bug when using mouse in orthographic mode

Latest Blender 2.8:

  • go into iorthographic mode, switch to orthographic view (front / top / etc.)
  • click middle mouse button to rotate view
    BUG: you are now in perspective view.

Please, fix it, it’s a showstopper.

Go to Edit>User Preferences>Interface tab
Disable Auto Perspective.

Wow, thanks! sorry for spamming then. (although I think that this mode should be disabled by default).


Disabling Auto Perspective fixes the problem, but behavior is still different from previous Blender versions.

In 2.79 pressing numpad 1, 3 or 7 changes the view to orthographic projection. Moving the view afterwards with middle mouse button doesn’t change projection back to perspective.

In 2.80 pressing numpad 1, 3 or 7 changes the view to orthographic projection, but moving it afterwards makes it go back to perspective projection.

Disabling Auto Perspective in 2.80 makes it so when you press numpad 1, 3 or 7 the projection doesn’t change to orthographic in the first place. If the user was using perspective projection it’ll be kept that way.

Is this by design?

I tested here, and in 2.79 (auto perspective OFF) If I’m on perspective mode and press 1,3 or 7 it remains in perspective mode, requiring pressing 5 to go to ortographic.

It only goes automatically from ortographic to perspective after pressing 1,3 or 7, when I have auto perspective ON.

Which is a questionable behavior regardless of apparently not having changed from 2.79 to 2.8.

I +1 to this being default.

So anoying for 2.7x users. It should be like before. If I am modeling and I want the viewport to be in orthographic mode I do not want it to change to perspective automatically, that is logical I think. Well now I know I can change it on 2.80 after having wasted a lot of time and frustration with this. On the final release of 2.80 it has been moved to Preferences/Navigation