Blender viewport vs multi-GPU trough pci-e riser issue

I have a Workstation with one 1070 on it. And I have three other gtx connected trough pci-e risers. Rendering lighting fast.
The problem is that Blender viewport is using (checked in HWMonitor) the gtx1080 pluged trough the riser to update/shade the viewport. Like so viewport is very VERY SLOWER than if I disable the 1080 in the device manager and Blender start to use the pci-e 16x 1070.
I tried to disable all other CUDA devices exept the 1070 on user preferences but Blender is still using the 1080 unless I disable the gpu trough device manager.
I think Blender is just using the device it think is the faster available and not taking in account the riser that slow it down for the realtime.

This is probably best handled through the bug tracker. Particularly the output from Help > System Info would be important here.

I’m not sure I fully understand the question though, are you saying that Blender OpenGL viewport drawing is using the GTX 1080? If so Cycles and its settings has no influence on that. This would be configured somewhere in the operating system or driver settings, which graphics card is used to drive which monitor.

Thank you, and yes I think youre right. How can I change the OpenGL to be the 1070 instead of 1080?

Just plugging the monitor cable into the graphics card you want to use might work?

Other than that look through the operating systems display settings or NVIDIA driver settings, I don’t know off hand where the right settings are.

Unfortunately it does not. The monitor is already on the 1070. And I cant find such setting on Nvidia Panel.

Solved :grin:
Nvidia Control Panel > Manage 3d settings > select preferred graphics processor
found here:

Thanks brecht :+1::+1: for the OpenGL tip