Blender gpu not found cycles/cuda

Hi,

Im new to blender and als to this forum.
I recently bought a new laptop to develop my skills with 3d animation and blender.
However I can’t select my gpu for rendering. Cuda doesnt show any option and when I render it takes ages because it only uses the CPU. I think there is a compatibility issue with the latest versions of blender. I tried 2.79 and there were no problems.

I bought the Asus ROG GA502IU-AL011T R7-4800H,16/1TB,1660Ti.

I searched the web for a solution and tried all the options (deselect internal gpu, cuda toolkit) Nothing worked and drove me mad.

Is this a commen problem and do I need to wait for a future update? Or does someone know the solution to this problem?

Not sure this is the correct category or forum to go to tho.

Cheers,

Daniël

Which operating system and which GPU?

Which Blender versions did you test? Did you try the latest daily build?

Hi brecht,

Thx for your reply.
Tried the 2.8, 2.82a and 2.83 beta version. I also tried it on windows 10 and latest version of ubuntu.

On both systems it failed unfortunately.

Is it possible that the new amd chipset is conflicting in some way?

Regards,

Daniël

On Windows, try running blender_debug_gpu.cmd in the Blender folder, go to Preferences > System and quit blender. After that there will be log files which you can attach here, they might have more information about this.

Dear brecht,

Unfortunately I returned the laptop because I had to stay within the free return policy and because there are a lot of new developments at laptop suppliers at the moment. I made a log before tho and there it recognised the gpu.
However when rendering it only used the CPU.
In the render settings I couldnt select the GPU.

Eventhough I returned the laptop Im still interested in whats going on because Im looking for a different laptop and dont want the same problems as before. I would alter my choice in specs to meet blender requirments.

Regards,

Daniël

I can’t really guess what is going on. I would expect it to work if you install the latest NVIDIA drivers. And if it doesn’t work, the logs would likely have shown information about why.

Hi, some user had problems with laptop include two GPU, integrated and “external” from Nvidia for example.
Blender may start on the iGPU for power savings and don´t recognise the Nvidia card.
You can change this in Nvidia settings and/or in the context menu of the desktop shortcut of Blender.
This is a only a guess but you may check if the next laptop does not work, too.

Cheers, mib

Hi Mib,

Tried this option aswell and also disabling the entire iGPU. Unfortunately it didnt work. I still think it has something to do with the newer versions of blender since 2.79 there were no problems selecting and using the 1660 ti GPU for rendering.

Im considering to postpone my purchase because my main reason to buy a new laptop is developing my 3d animation/printing skills.

Regards,

Daniël

You forgot to upload the log files. :hugs:

Before I returned the laptop I erased the storage and recovered it to factory settings. Therefore I can’t upload the log. However when I reviewed the log it showed the GPU and therefore no red flags came to my mind. It’s probably a good idea to continue this thread till someone else experiences this problem with hardware on hand or to wait untill I purchase my new laptop.

Regards,

Daniël

How can I check log in kubuntu?

Run blender --debug-cycles to get print detailed Cycles logs while rendering.

Hello,

I had this issue today. I have a Lenovo P53 Thinkpad with an RTX GPU. I was in Blender 3.1 and noticed for the first time that I didn’t have the option to choose my video card. Blender claimed not to see my card. I have been doing a lot of NVidia driver and library installs lately to get some ML scripts to compile and realized that the environment variables that were new to my system might have something to do with it, so I renamed some of the variables by putting “TEMP_” in front of each of these and Blender now sees the GPU. Examples below with the values:

TEMP_CUDA_PATH
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v11.6

TEMP_CUDA_PATH_V11_6
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v11.6

TEMP_CUDA_VISIBLE_DEVICES
1

Blender began seeing my card again. The CUDA_PATH entries don’t have anything to do with it, so I set those back, but when I put the CUDA_VISIBLE_DEVICES variable back as original, it couldn’t see my GPU. So I changed the value to 0 and it sees it again. I have an integrated graphics card (Intel) on my machine also, which it’s also seeing when set to 0, so either renaming the variable or setting it to another number based on your situation may help.

When CUDA_VISIBLE_DEVICES is set to 1
“No compatible GPUs found for Cycles
Requires NVIDIA GPU with compute capability 3.0”

When CUDA_VISIBLE_DEVICES is set to 0

I hope this helps, because I looked at a few sites for a solution and didn’t see an immediate fix except for reinstalling the drivers, which wouldn’t have worked for me.

Thanks for an amazing community and application.

-EsDog

2 Likes