Blender Bridge Edit Loops

What is the principle of Interpolation in Blender?
Nothing is written in the documentation.
Is this a bug?

Blend Path:

  1. Create two cubes
  2. Remove the top faces
  3. At the second cube, extrude edge
  4. Deselect
  5. Select edge in the first cube, then in the second
  6. Apply the command Bridge Edit Loops
  7. In the settings should be everything by default with interpolation “Blend Path”
  8. Increase the number of cuts

bel

Blend Surface:

  1. Create two cubes
  2. Remove the top faces
  3. At the second cube, extrude edge
  4. Deselect
  5. Select edge in the first cube, then in the second
  6. Apply the command Bridge Edit Loops
  7. In the settings, select interpolation “Blend Surface”
  8. Increase the number of cuts
  9. Set the Twist to 1

bel_bs

LoopTools

  1. Create two cubes
  2. Remove the top faces
  3. At the second cube, extrude edge
  4. Deselect
  5. Select edge in the first cube, then in the second
  6. In LoopTools, select Bridge
  7. Increase the number of segments
  8. Choose a team Reverse

lt

1 Like

Might be worth reporting this type of behavior as a bug on developer.blender.org.

1 Like

it seems like a bug,
it can’t handle bridge between loops that on the same surface angle.

If you rotate slightly cube edge loop it bridge as expected.
I think it some sort of limitation for bridge tool, but would be nice if it could work like your first examples.

Experimented with angles when bridge start to work as expected and found angle in 6.36 degree, below this angle - not working.

or in blender - help - report a bug
if you report a bug, pls, put a link here, I want to subscribe

1 Like

Don’t bother reporting, there’s one in from over 2 years ago. Might be worth adding that the report was resubmitted because the guy reporting it couldn’t find his several years old report from the last time he put it in.

1 Like

Many developers are subscribed to this token, so I just added a link to this post. Thx.

This is still relevant.
https://developer.blender.org/T54996

2 Likes

Please report this as a new bug. While T54996 is a complex case which fails, this has a more obvious solution as this is not “multiple rows of faces facing each other”.

Made some tests again


cant even understand how it chooses normals.
I think best solution in this case will be add option to Reverse direction or even Reverse Direction for both selection individually: “Reverse first Direction” and "Reverse last Direction"
P.S. can’t upload blend file…

@ideasman42
https://developer.blender.org/T79375
done