Blender 2.8 particle system using a collection, need objects to be enabled for rendering


#1

When choosing “Render As” collection under Particles->Render (Emitter or Hair doesnt matter) all the objects of the collection have to be enabled for rendering or they won’t show up.

In Blender 2.8 it is possible to “Render As” an Object and disable that object for rendering, but it will still show up in the particle system. This makes sense since you often only design the Object to be featured in the particle system and you need to hide it somewhere in the scene otherwise. It would just be logical and intuitive to experience the same behavior with collections.

It cost me quite some time to figure out, why my particles won’t render. Probably because I’m still quite new to Blender and switched early to the Beta. I checked back in Blender 2.79 groups and single objects, both need to be enabled for rendering to show up in the particle system. So being able to render disabled objects in particle systems is new to Blender 2.8, I guess?

This behavior is very useful, but the inconsistency can really lead to confusion, especially because the objects in the collection can be disabled for the viewport but will still render in the particle system (even in rendered view). This is not the case for the actual final render!

The two uploaded images illustrate the described issue.
You guys make a great job.

Greetings
Accelero


#2

Glad I came across your post. I was having the same trouble. I have a collection with all unrendered objects. One of those object is specifically for the particle shapes. Guess I’ll have to move this off screen for now.


#3

Glad it helped someone. It also took me some time to to realize why my render misses only some of the particles (those from collections).


#4

Quick google search got me here. Just got the same issue. Particles show on viewport but not on final render.