Blender 2.8 Eevee - Clipping shadow problem


I am trying to set this architecture scene with eevee, but the shadows from the sun lamp keep clipping when you get close to the model. It is like Eevee only renders the shadows from the objects that are within the viewport limits. If there is something outside the view you won’t see its shadow.
I know I am probably doing something very wong here, cause I’ve already seen some great architecture visualizations with eevee and without this problem.

Does someone know a way around this? Maybe tell me what is the stupid thing I am doing, haha… Is there a way to bake the shadows? I already tryed baking indirect light, but it doesn’t bake the shadows.

If this is not appropriate for this forum, let me know.

Anyway, thanks in advance!

This happens because you are using Contact Shadows to fill in part of your scene. Contact Shadows are a screen space effect, as doesn’t work if the item casting the shadow is off screen.

To solve it, make sure that the regular shadows cast useful shadows in your scene first. Contact Shadows are only meant for tiny shadows that appear close to objects.

Hope this helps.

1 Like

Thanks for the quick reply!
I will turn off contact shadows! But do you have some idea how I can make sure regular shadows cast useful shadows? Is it by moving the light source, rotating it? Because it seems like there is a limit distance for the regular shadows to cast on other objects, which is smaller than the distance from the roof to the floor… So it is like there is no shadow from the roof.
But I will definetelly try rotating the sun lamp to see if it works better in another angle.

Thanks again!

Shadows in Eevee are only cast from the sun light forward from the sun itself. So you have to move the sun further away so it encompasses the entire house. If you put a sun lamp in the middle of the scene, it only casts shadows on one half on your scene.

You can still use Contact Shadows, but only for, well, contact shadows.



Ahhh it worked!! Hahaha! That simple! I thought sun lamp worked like in cycles, where it does not matter the position of the lamp, only the rotation.

Thank you very much!!

You drop a sun into your scene and shadows most likely will appear somewhere far away from your camera.
Near clip plane inherits sun object rotation, so after adjusting your sun rotation, you may need to adjust its position, just to have shadows everywhere you need.
I can’t imagine any case when you want shadows to be only somewhere in the middle of your scene, far away from active camera.
Sun shadows should be drawn relatively to user’s viewport, just like in all other realtime 3d engines.

For me this behavior looks wrong.
Thought experiment - animate a day cycle in eevee. You need to animate not only sun rotation, but its location as well, because you need to control manually that all your objects don’t go outside shadow clipping planes.
If your camera moves, you have to move the sun as well, or eventually your camera will get out of sun frustum.

Hey guys, I know this is an old thread but since I’ve been having this same problem and this thread came up in all of my searches I figure this would be a good place to post what ended up being my solution. Moving the sun didn’t have any effect on my scene to preserve my shadows, but what I found did fix the problem was actually my Viewport Clip Start/End settings. Since the shadows looked fine through the camera I finally figured that the issue had to be the viewport.

In the top image, you can see the clipping I was experiencing and the corresponding settings on the right.
On the bottom was how it looked after I had changed my “CLIP START” setting (if this doesn’t work tryi adjusting your “CLIP END” setting). This is also how it would always look through my camera regardless.

I hope this helps someone who runs into the same problem and doesn’t know where to start to fix the issue!