Blendcache folder name - should it be changed?

Baked simulation data from Cloth, Smoke and Soft Body are saved in a folder called “blendcache_$file”. Those from Fluid simulation default to “cache_$file”.


  1. In the UI, “cache” generally refers to volatile data

  2. In the English language and in computing in general, “cache” refers to a hidden, temporary storage.
    The “blendcache” folder is neither volatile (it should be kept with great care!) nor hidden or temporary.

The stable version of a simulation cache is referred to as “bake” within the program. Shouldn’t the folder name be changed to something that reflects its stability? “blendbake” or “bakedata” come to mind.

Legacy files should be easily dealt with, by making blender look for any of those two names when reading, but only using the new convention when initiating a new bake.

(Inspired by this BSE question)