Beginner's Issues - lag issues 2d animation grease pencil

Hi everyone,
sorry if I overcome a few rules maybe, this is my first post here , and english isn’t my native language.

CPU : i9-9900k
GPU : RTX 2070 8GB GDDR6

I’m posting here because i’ve been trying out blender recently, mainly for its grease pencil functionnality.
Got used to the basic tools and did a few tests (like a 4 second 2d simple animation using a armature bone to move and squish the grease pencil object, no problem until there).

Then i started yesterday to have 1 simple character i designed (1 GP object “body”, 3 layers "Line, Fills and Shadows) move over about 50 frames. No bones used, i simply edited and sculpted my GP object for each frame.
But as i went further and further into inserting new KeyFrames, the software started lagging out on me more and more… Tried it both by making a few keyframes poses myself and then asking blender to interpolate keyframe sequences, and also by making every keyframes pose myself.

Both times it does the same and just lags more for every added Keyframe, and around 40 to 50 (which is not a lot…) it lags so much it becomes unworkable…

Only thing is it only lags out in Edit or Sculpt mode…

I am quite new with this software and have been searching a couple hours on internet to see if someone had the same issue, but did not find any relevant post , and came here for help.

Hoping someone here has the knowledge to help me.
I could record the thing happening if needed.

Thank you in advance to whoever respond to this ^^’

Are you using multiframe editing ?
That is an option only available in those modes + weight paint mode.

Found it, no i wasn’t using it, it was grey.

Here are the two files (one where i asked for interpolating sequences, the other where i quickly put about 50 keyframes to check if it lagged aswell).

Any ideas? downloadable files are not going to stay too much longer, if they’re not working anymore, tell me i’ll reupload them.

Please Halp


Thanks to Daniel Martinez Lara alias @pepeland on Twitter, he noticed that my GP object simply had to many vertices (almost 3 millions for 1 character when “Hero” ‘s most complicated scene had about 1.5 million for about 10 characters ^^’), and that i just had to add a simplify modifier to the GP object and VOILA! Problem fixed!

Thanks to him and still thanks to anyone here who took the time to read this post, I hope this simple mistake post might help a future beginner :stuck_out_tongue:

See you next mistake!

Could you tell me what a simplify modifier is? I have the same problem and cannot find answers

Please see,