Asset browser is empty and I can't create assets

Hi, I’ve been trying to use Blender’s asset manager for a while now but can’t find a proper version on which it works. Or maybe I’m doing something wrong.

I tried downloading all the experimental builds I could find but the best I can get is what you see on my screen capture.

To summeries: the asset browser editor is empty. All it shows in the source list is a greyed out tab for Pose Library and that’s it! I don’t have all the diffrent data blocks displayed.
Also, I can’t mark an object as “asset”.

I also tried installing the latest 3.0 Alpha build on another computer that did not have Blender installed and it did not work either.

I’m desperate to find a solution and don’t know where to ask for help so please, if this is not the right place, I’m sorry. Could you tell me where I can ask my question pls ?

Best regards,

The asset browser is still under heavy development and not ready yet. the Pose library v2 is the ready part which you can see in the screenshot you shared. To be able to use the asset browser and also able to mark objects as assets. you need to enable the asset browser from interface - developer extras then from the experimental menu enable the extended asset brower in the preferences.

Devtalk is a place for developers and contributors to communicate. Next time in need for help, you can use the Blender chat Support channel


Thanks a lot for the answer !!!
Will go to the chat support channel next time. :wink: