Animation Editors Tweak (Fixing Difficulty with Hidden Objects)

Objects animated to hide/un-hide are a huge hassle since their keyframes disappear in animation editors once the object is hidden.
(this could go in the paper-cuts section, but I think its scope is too big)

  • One would think to enable Display Hidden in the Dope Sheet or Graph Editor to view the keyframes, but this does not work because hidden objects also become deselected :confused:
  • Sure, one could disable Only Selected, but that clutters the editor with other objects’ keyframes.
  • The keyframes are impossible to view in the Timeline since the two above options don’t even exist for it.
  • Getting around the problem by animating only the Render Visibility, but not the Viewport Visibility, is impracticable since the animation cannot be properly previewed.

Make all animation editors display what is selected in the outliner, rather than the viewport.

  • Objects stay selected in the outliner even when they are hidden :slight_smile:
  • This change would be less noticeable with the upcoming synced selection for the outliner. When someone runs into this problem, they could simply disable the sync.

if you check display hidden and display only selected it shows whatever you have selected even if its hidden, i believe that option should be turned on by default not as stupid as it is now.

Right, but hidden objects cannot be selected once they’re hidden, not in the viewport (correct if I’m missing something here :slight_smile: ).

correct, but select them when they are visible, and then they dont get deselected,.

Objects aren’t deselected after they’ve been un-hidden. But while they’re hidden, they become deselected, so their keyframes aren’t displayed in animation editors that have Only-Selected enabled.

Just so where on the same page, here’s what I’m talking about:

  • Startup blender

  • Make some keyframes for the location of the default cube

  • Open a Dope Sheet with Display Hidden and Only Selected enabled

  • Currently, the cube’s keyframes should be visible in the Dope Sheet

  • With the cube selected, go to the outliner and check Disable in Viewports (monitor icon) to hide the cube

  • Now, the cube’s keyframes aren’t displayed in the Dope Sheet
    I think this is because the cube is no longer selected in the viewport

This also happens if you animate the cube to hide for some period of time: While the cube is hidden, its keyframes in the Dope Sheet aren’t visible.

Get the same results?