About Cycles in 2.79 and 2.8 and bound "bounding box"

In 2.79 when you make viewport rendering and in viewport you have many objects with high poly count - in render time blender remain object in bounds representation if you set it for them.
BUT
In 2.80 when you make viewport rendering and in viewport you have many objects with high poly count - in render time blender make those object not in bounds representation but full solid and viewport because of that star work very slow, i understand why slow - i make them bounds representation because of that BUT WHY 2.80 make them solid when it already setted as bounds? And in 2.79 all fine. Same scene, Same file…
Probably this is bug in 2.80?

Here i recorded video where show this

here is scene file if needed https://cloud.mail.ru/public/DjDt/4hLuPxucW

There is no bounding box display in 2.8 currently. But we should indeed find a solution for this kind of problem, not sure exactly in what form.

make bounding box display? like in houdini u set polygon limit on sceen. and the object farest from camera is swaped to bounding box. or there is kinda voxelisation of it. like many small bounding box like BVH display kinda of way. or override all objects and make bounding box display.

1 Like

did you tried what you suggest or you just…?

i mean it works in houdini… would love to see it in blender… if we are going to fix this problem and generaly bounding box and navigation on huge sceens might acctauly improve it…

hi brecht
is there any news about? “There is no bounding box display in 2.8 currently.”
may be just do as this been in 2.7?
at least for a time being

1 Like

There’s no news yet.

hi brecht
I just reminds about this feature.
I am still do not understand for blender studio make short videos without this…:wink:

Bit of a nightmare not having bounding box display I agree, especially if you’re generating new geometry on the fly.

If you’re not generating geometry on the fly then you can select all objects and then set them all to bounding box at the same time in the objects panel by holding alt when you select bounding box from the display as dropdown.

Hope this gets addressed though :frowning:

3di you did not understand about what this topic. again blender 2.8 make all objects marked as “bounding box” IN RENDER TIME CONVERT its ALL to shaded display mode - and all them SLOW DOWN viewport drastically!!! - checked just now - same as i write in first post NOV 2018…nothing changed

ah ok sorry, I didn’t read it properly, I thought you where complaining that there was no longer a bounding box viewport display.

I’m not sure what you mean though, 2.8 viewport render is working the same as 2.79b for me. If I have a particle system set to hair and use it to instance a suzanne (and the suzanne is set to display as bounds in it’s object properties panel), then it displays bounds in the viewport for all instances, but renders as solid in the viewport render, the same as 2.79b. It does overlay the bounding box in the render now too, but I just turn that off by disabling the overlay button.

in first post are video if you want then you can understand from it, if not - then - not…

for me matter that brecht understand about what i talk, i hope devs soon fix what i ask

hi brecht - there are past almost 1 year from my first post - and blender still in render time behave same. Is there are some obstacles in order to realize what described? Maybe just bring functionality as they been in 2.79?

Any hopes that this issue will addressed at all? And what about missing bounding box display anyway?

@Striletsky EEVEE has bounding boxes working as expected. And as far as I can tell Cycles is also working as in 2.79.

If there is still any remaining issue it should be reported to developer.blender.org where the development team can properly look at it.

And as far as I can tell Cycles is also working as in 2.79.

no, it isn’t, just now testet in latest daily. same there

it should be reported to

i will try

@dfelinto, Blender 2.7 had a bounding box display mode, where all objects are displayed as bounding boxes. For heavy scenes it would be useful to add this back in 2.8.

Bounding box display can also be set for individual objects of course, but it’s not convenient since you’d have to switch it off whenever you do want to edit and see the actual shape of the object in the viewport.

We could add a task for this in the viewport module.

2 Likes

What could be useful too is a callback that automatically enable the bounding box view mode when the FPS goes below a threshold configured by the user, that feature should be automatically enabled by a checkbox in the Viewport Shading menu, there could be an FPS threshold besides the checkbox.

This will make way easier to handle big and complex scenes, as soon as the view stops moving it should return to it’s previous mode.

If the bounding box mode is added maybe this can also be added at the same time to ease working with big scenes :slight_smile:

2 Likes

I was looking for a way to convert all selected items to bounding box, appears I can only do that per one object - if someone can help me great.
But also this suggestion, for when the fps of the viewport falls below a threshold to have object appear as bounding box is something I think 3dsmax has implemented - it’s not all perfect but you can move around when the scene is very heavy, that’s why I’m looking for this convert to bounding box all selected objects - finding a way to optimize viewport…
Another approach that plugins do is make a sort of “point cloud”, so a small amount of vertex or bigger triangles that look like the silhouete of the object, and uses vertex color, but it probably takes like 10-20 vertex of memory… that works best - that and bounding box combined - sometimes you just want stuff obstructing your view as a bounding box…

1 Like

When you have all the objects selected, and you have one of them as active one, you go to the Viewport Visibility options, open the “Display As” list and before you pick one press the ALT key, then click on one mode, all the objects will change it’s viewport visibility mode at once :slight_smile: