3d cursor when mapped to hotkey will only snap to surface, ignoring snap enable/disable and snap element types

I posted this issue as a bug on developer.blender and was informed that it was a feature request to have the hotkey assigned 3d cursor match functionality with the new 3d cursor tool.

When assigning the 3d cursor to a custom hotkey, ex: shift_mmb the 3d cursor cannot be dragged and will only snap to surface/face. Even if snap is not enabled the placement is snapped to face. The 3d cursor will not snap to specific snap element types, ex: vertex or edge. This is in contrast to using the 3d cursor tool, with its default behavior of being able to drag the 3d cursor around and it will respect snapping enabled/disabled as well as snap to element types like vertex, etc.

Sorry, I made a mistake. There is only one tool.
That is working as you described it for new default keymap with shift RMB.
But dragging does not work for 2.7x keymap to avoid confusion of users, used to previous Blender versions.

As a consequence, it looks like dragging is disabled for Industry Keymap, too.
The Todo task is to be able to allow keymaps different than default one to use dragging.