3D Cursor rotation issue

Hi, when I press [shift] + [RMB] on object mode the 3D cursor snaps to the current object’s face that is above the mouse cursor but with a weird angle added to it, as you can see on this example :

Issue with 3D cursor rotation

Witch makes the add geometry tools not that great to use. Actually personally I don’t use those tools for now but sometimes that could get useful in the future.

Try to use the “Geometry” feature of the 3D Cursor tool…

1 Like

Was about to reply with this screenshot:


But a video beats that.

1 Like

I tried, but when you snap by pressing [shift] + [rmb] this doesn’t work right :

One more example of the Issue with 3D cursor rotation

1 Like

Why not just use the cursor tool? I guess shift + rmb is not meant for this.

This is an user feedback area so, I’m reporting a problem with the program. I don’t like to change tool every time I need to place the cursor. And [shift] + [rmb] should follow the cursor tool options cause now it only uses screen space rotation. I find that very annoying and I think it must be consistent with the tool. those “why not” answers doesn’t help bugs to get fixed. Just think some people could work different than you do and you’ll find your answer meaningless.

1 Like

I just suggested something.

Have a nice day Sir.

Damn. :man_facepalming:

If you saw the 2nd video, you saw me using the cursor tool. I know its existence so, there’s no point on throw a comment that tells me like: “You know what just use the cursor tool !” Sorry but that doesn’t help much. It’s all I’m saying… Good evening.

It would be reasonable and more user-friendly to have the same settings for both.

1 Like