2.92 - UI issues

  • when changing view by dragging mouse from plain axis view (i.e. numpad 1) display mode changes from ortho to perspective view. That looks ugly, as model looks clobbered
  • when changing view by dragging mouse from plain axis view (i.e. numpad 1) zoom factor changes, so that viewpoint is inside model, whereas in ortho mode it shows the whole model

Turn this option off in the Blender preferences:

Try changing these values (lower Clip Start and increase End):


Thank you very much for your help!
I wasn’t aware of that option. Works fine for me!

Respect to clipping: I wasn’t talking about clipping. I already changed clip-limits to avoid clipping. I use blender units as Millimeters (units none) and set clipping from 0.0001 to 100000 - which usually includes my whole model.

This is how my model looks in perspective view:

… but - never mind! I’m fine with the auto-perspective option set to off.

Thank you!

1 Like

You’re welcome.

The screenshot has heavy JPG compression, but polygons that coincide at the exact same level can cause artifacts. Also, did you check and apply the scale of your objects (select objects, press Control + A ➔ Apply Scale) ? Maybe your scene is extremely large or small?

You might also want to activate these options:

Thank you for your support!

That artifacts come from gimp or jpeg, not from blender. I shrinked the screenshot and increased jpeg compression, as I didn’t want to abuse forum space.
No, what I mean is the partial rendering of hidden surfaces - and that surfaces are not at the same location (don’t know, what level means).

Formerly I created cubes with default size and sized them by changing item dimensions. But when I discovered that bevel depends on scale factor, I changed my habit and now I try to always use scale of 1 - but of cause, I have lot of old stuff.

Orbit around selection was already checked. So I tested both options, but I can’t see any difference with active or inactive state.

1 Like

I also use mm for architect modeling. This settings seems ok to me.

Thank you for the hint!
5mm for lower limit works fine with 2.92 :slight_smile:

I stil use 2.79 for work and regularly check prereleases whether current version would be usable for me/my habit of blender usage. So formerly I had issues with clipping and solved that by lowering clipstart.
May be that changed. Fine!

By widening the clipping range (i.e. lowering the Clip Start and/or increasing Clip End) you’re effectively lowering the accuracy of depth test, which introduces Z-fighting. You should really keep the Clip End no further than needed, and Clip Start as far as possible.
This is not exclusive to current Blender versions, it pretty much was always the case.

1 Like

So now I know a name for that strange rendering in perspective mode. Thanks.

But I never cared about that Z-fighting, as 2.79 does not have that auto perspective setting. With default view settings I always had trouble with clipping - even with small models.
Widening the view range was result of trial and error which worked for me. Didn’t know about side effects.

Ok, so I already learned from apec, that higher lower limit works smarter. I’ll keep an eye on that.

Thank you!

1 Like