2.92, Optix CPU + GPU is slower than GPU only

Please, “CPU only” render time is also relevant, especially to know from how many times faster GPU has to be for CPU+GPU render to have a real benefit.

So I’ve been intending to run my own tests with this, as I am currently running a 3950x and a 2070 super, and was curious to see how the cpu affects rendering times.

Except it doesn’t seem to work. I can render in 2.92 using the GPU or the CPU alone with optix, but if I try and render using both… I mean it renders the scene, but for some reason it renders it extremely fast, and leaves it very noisy, as if it’s only rendering with a couple of samples instead of 800 (this is on barbershop).

I can’t find any issues on my end, so I can only assume it’s a 2.92 bug, but you guys seem to be having no issue!

This is not a suitable scene for testing with OptiX:

Ahhh ok, that makes sense then I guess, so which benchmark scenes are appropriate to run tests on this?

These two scenes for example:

Or any other scene that is configured to use Path Tracing…

thankyou, much appreciated :slight_smile:

Ok so in case this is of interest / use to this thread I thought I’d add my first pass of tests to the data pool. This was done on the classroom test.

CPU = Ryzen 3950x
GPU = RTX 2070 super

64px tilesize:
CPU only = 4m 53s
GPU only = 2m 00s
GPU+CPU = 1m 26s

256px tilesize
CPU only = 5m 34s
GPU only = 1m 51s
GPU+CPU = 1m 33s

And as a comparison, I did a GPU+CPU cuda run on 64px, and that was 2m02s.

So it seems that GPU optix is running at around the same speed as GPU+CPU cuda, and being able to add cpu to the optix rendering is improving render times by a decent chunk.

However I suspect that if I was running a 3080, the speed of the gpu would outweigh the ability of the cpu to contribute.

Has anybody got tile stealing to work yet? It doesn’t seem to work on my PC - no matter if I use CUDA or Optix. Is there a setting that I have overseen?

Hi, it is working for me with Cuda and Optix on RTX 2060 and i5 3570K.
Linux and latest buildbot build but work on Windows, too.
There is nothing to setup, all automatic.
If you have a fast CPU you may not see it working with small tiles, test 256x256 at least.

Cheers, mib


I’m on Windows 10 (64-Bit) using the latest nightly build of 2.92. Here’s a screenshot of the task manager. As you can see, the CUDA performance is back to zero while the CPU still has several buckets going.

OK, I test again with Optix/Cuda and CPU and can verify: It does not work.
Sometimes it seams the GPU steal one tile but leave other CPU tiles running on CPU.
May be it is time to report a bug.
For me and my old CPU it is not useful anyway but if you cant report I can do it.

Cheers, mib
EDIT: Will check on Linux, if I find some time.

1 Like

If you are familiar with the bug reporting process, I’d appreciate if you could do it. I’m not doing that too often. Cheers.

I can do but I am still not sure if it work or not.
I had adaptive sampling enabled in my test file and preparing it for the bug report I disabled it. Does not matter it work.
Can you please render my test file?
It is 4K with huge tile settings, I can see the effect better with big tiles.

Cool, you cant upload .blend files in the Blender forum.

Cheers, mib

Oddly enough, tile stealing worked with your scene. After some investigation is seems as if tile stealing doesn’t work when “NLM” denoising is selected (it doesn’t even have to be activated) for rendering. But as I always use Blender’s default denoising, I don’t really want to deactivate it. Tile stealing seems to work with OIDN.

I try to poke @lukasstockner97 if it is a missing feature or a bug.
Stay tuned, mib

1 Like

Hi, just for info, I had contact to @lukasstockner97 in blender.chat and he told me it is supposed to work with NLM.
He will look in to it.

Cheers, mib


Thanks a lot - much appreciated.

1 Like

Little addition. Tile stealing also fails when you have “Denoising Data” checked in the Passes section even when Denoising is unchecked in the Render Properties. @lukasstockner97

Oh! That’s bad :s
Let’s hope this is fixed soon.

Hi, I guess I will report these two issues to the bug tracker.
Sometimes the chat reports get lost in space when the developer is busy with other things and I cant follow all commits from the mail list at moment.
Will edit the bug numbers here.

Cheers, mib