Windows: How would I fix clangd intellisense for Blender?

Everything builds just fine using the make.bat (debug development)

Do I have to update the compile_commands.json after building/installing deps (and if so, how would I do that)?

Any knowledge appreciated <3

If you run cmake.exe -DCMAKE_EXPORT_COMPILE_COMMANDS=ON followed by other options, it should create/update compile_commands.json as needed in the build folder. One doesn’t need to build stuff to create the json file that way.

You might need to set that path in VScode/project settings though.

Although clang on windows for blender is not tested regularly, so not a guarantee that you’ll succeed in making it work. Visual studio is recommended.