Windows Build: 'stdosl.h' file not found

Hi All! I trying to build blender in a Windows 10 VM (VirtualBox), tried to follow all the wiki build steps, but I keep getting the following error, and when I use the absolute path to stdosl.h from the blender-git/lib/win64_vc15/osl/share/OSL/shaders/stdosl.h (looks like FindOSL.cmake does not find it?), I get a bunch of “symbol aready defined” errors. Any clues?

The exact same code builds fine on my macos host machine as well as with a docker Ubuntu container (repo folder shared by all 3 environments).

Tried Visual Studio 2022, 2019, also, tried master as well as blender-v3.4 branches with same result.

Thanks in advance for any help!

Generating node_absorption_volume.oso
CUSTOMBUILD : error : In file included from C:/blender-git/blender/intern/cycles/kernel/osl/shaders/node_absorption_volume.osl:5: [C:\blender-git\build_windows_x64_vc16_Release\intern\cycles\kernel\osl\shaders\cycles_osl_shaders.vcxproj]
  C:/blender-git/blender/intern/cycles/kernel/osl/shaders\stdcycles.h:12:10: fatal error: 'stdosl.h' file not found
  #include "stdosl.h"
  FAILED C:/blender-git/blender/intern/cycles/kernel/osl/shaders/node_absorption_volume.osl