[Webpage] Can no longer see blender's development schedule


When pressing “See schedule” , it redirects me to blender.org instead of the schedule and workflow page, Tested with both “brave” and “Firefox” browsers (Versions aren’t important since the issue is valid on both browsers).

Hoping for a fix soon, Thanks in advance and i really don’t care if its not the right place to post it, forward it to the right place.

Is not just that. Seems to me that something is broken in general with the hyperlinks to that page; The same happened to me yesterday with some other random link I don’t remember.
And again this morning in the first link of this one that is supposed to get you to download the bundle, but in reality it also redirects you to the main page of the developer portal.

PS: also checked in multiple browsers (firefox and chrome)

1 Like

Alright, Need a moderator here to confirm that the problem is known to the developers and upon request, i will provide any technical information if required.

Works here and now. Possibly some leftover bits from the Gitea migration. If you are still having problems, you may need to refresh your browser cache.

No more access to dev history page?


https://projects.blender.org/blender/blender/commits/branch/main :thinking:

1 Like

Thank you… my favorite news blog is back :slightly_smiling_face:

I don’t know. I cleared the data and I still get the same thing. Can someone confirm?

In this Geometry Nodes meeting thread, the links for workboard and patches at the top redirect me to the developer portal, no matter what. (tried in firefox and chrome, both in regular and incognito mode)

it just that the links havent been fixed yet but new project exists here Nodes and physics

reason why the update took time is this

I don’t see issues here, the links mentioned above work fine for me. For example the 3.5 link for the schedule 3.5 - blender - Blender Projects

In the Geometry Nodes > General section of 3.5 Wiki page:

These 2 links don’t seem to work:

They both are showing blank 404 error pages:

Thanks, I fixed the two links now.

1 Like

You’re right. But have you tried the link I mention in the second comment of the thread?

In that page, there is this link to the assets bundle

And this is where it gets me (checked right now):

Maybe there is something wrong with just a specific couple of links, but the thing is I bumped into the same issue for a couple days, always redirecting to the developer landing page, so I assumed there was something broken. I posted those two as examples, I think there were more.

I am currently working on it. Gitea may have left behind unused components. In the event that you are still experiencing problems, you may want to refresh your browser’s cache.