'Unresolved external symbol' when building 2.90.1 on Windows 10 using make ninja sccache

Since I have started using sccache, I think I have only ever successfully updated my build twice before it fails. Instead of my usual route of trashing my build folder and starting a new one twice a week, I figure I would try asking for help for a change to see if these build issues can be solved another way.

What I think is the relevent part of the error:
Creating library bin\blender.lib and object bin\blender.exp
cycles_render.lib(scene.cpp.obj) : error LNK2019: unresolved external symbol "public: void __cdecl ccl::LightManager::device_free(class ccl::Device *,class ccl::DeviceScene *)" (?device_free@LightManager@ccl@@QEAAXPEAVDevice@2@PEAVDeviceScene@2@@Z)
referenced in function "protected: void __cdecl ccl::Scene::free_memory(bool)" (?free_memory@Scene@ccl@@IEAAX_N@Z)
bin\blender.exe : fatal error LNK1120: 1 unresolved externals
ninja: build stopped: subcommand failed.
Error during build

The full logs of make update followed by make ninja sccache are attached below.

May.15.2020_make_update.txt (8.4 KB)

Build_error_May.15.2020._make_ninja_sccache.txt (8.8 KB)

Any ideas @LazyDodo @PrototypeNM?

Iā€™m guessing ninja is not picking up on changes due to outstanding bug #411 in sccache.

try tossing just scene.cpp.obj and see if it recovers

edit: linked the wrong issue

1 Like

Yep, that worked! Thanks @LazyDodo!