Unable to MAKE [SOLVED]

I don’t know if is a my problem or a Blender problem. Thank you
System Information
Operating system: Linux-6.7.0-arch3-1-x86_64-with-glibc2.38 64 Bits, X11 UI
Graphics card: Mesa Intel(R) HD Graphics 5500 (BDW GT2) Intel 4.6 (Core Profile) Mesa 23.3.4-arch1.2

Blender Version
Broken: version: 4.1.0 Alpha, branch: main, commit date: 2024-01-30 04:56, hash: 948e806a1a43
Worked: (newest version of Blender that worked as expected)
the version of 2 days ago

Short description of error
[Please fill out a short description of the error here]

Exact steps for others to reproduce the error
make[3]: *** [source/blender/compositor/CMakeFiles/bf_compositor.dir/build.make:233: source/blender/compositor/CMakeFiles/bf_compositor.dir/Unity/unity_15_cxx.cxx.o] Error 1
make[3]: *** Attesa per i processi non terminati…
make[3]: *** [source/blender/compositor/CMakeFiles/bf_compositor.dir/build.make:89: source/blender/compositor/CMakeFiles/bf_compositor.dir/Unity/unity_24_cxx.cxx.o] Error 1
make[3]: *** [source/blender/compositor/CMakeFiles/bf_compositor.dir/build.make:217: source/blender/compositor/CMakeFiles/bf_compositor.dir/Unity/unity_16_cxx.cxx.o] Error 1
make[3]: *** [source/blender/compositor/CMakeFiles/bf_compositor.dir/build.make:201: source/blender/compositor/CMakeFiles/bf_compositor.dir/Unity/unity_17_cxx.cxx.o] Error 1
make[2]: *** [CMakeFiles/Makefile2:8006: source/blender/compositor/CMakeFiles/bf_compositor.dir/all] Error 2
make[1]: *** [Makefile:166: all] Error 2
make: *** [GNUmakefile:387: all] Error 2

1 Like

Did you do all the steps described here: Building Blender - Blender Developer Documentation

1 Like

certainly, like every day.
make update

using main branch on linux
Thank you very much for your interest.

Looks like the same issue as:

Might be a temporary issue that resolves when you update again.

If not, would be good to see the full build log.

1 Like

Sorry, where i find the full build log?

In my shell I typed

$ make full > make_full.txt 2>&1

Then I uploaded make_full.txt in my message.

1 Like

Thank you very much, you are very kind, it works now but I will save the message for the future. now it compiles without errors, but I have rendering problems which I’m going to report in the other forum after having done a bit of testing.
A thousand thanks.

What did you do to get it to compile?

I currently have similar compilation errors when trying to compile on Linux Mint today.

make[3]: *** No rule to make target 'source/blender/compositor/CMakeFiles/bf_compositor.dir/cmake_pch.hxx.gch', needed by 'source/blender/compositor/CMakeFiles/bf_compositor.dir/Unity/unity_24_cxx.cxx.o'.  Stop.
make[2]: *** [CMakeFiles/Makefile2:8137: source/blender/compositor/CMakeFiles/bf_compositor.dir/all] Error 2

After an update of Arch (kernell and GCC) it works. i do nothing.
(I update Arch and blender very often, and maybe sometimes blender precedes Arch in changing some files, or maybe temporary problems when changing many things, I don’t know, I report any errors I find in the hope of helping)

1 Like

Thanks for the reply. I updated cmake to 3.28.2 yesterday, and in the MacOS thread mentioned a few posts above it looks like this is the cause.

What cmake version are you using?

1 Like

cmake version 3.28.2

CMake suite maintained and supported by Kitware (kitware.com/cmake).

Dang… that’s my version too. So that might not be the cause.

1 Like

The last Arch update:

binutils-2.42-1 curl-8.6.0-1 fakeroot-1.33-2 gcc-13.2.1-4 gcc-libs-13.2.1-4 glibc-2.38-8
libnghttp2-1.59.0-2 libpng-1.6.42-1 linux-6.7.2.arch1-2 opera-106.0.4998.70-1 sqlite-3.45.1-1

Thanks again. I downgraded to cmake 3.27.9 and all is shiny again.
I didn’t know that cmake can be too new, in the past I only had problems with cmake being too old :sweat_smile:

1 Like

Ah, there we have it:

P.S.: It’s about 3.28.2 obviously, not 2.28.2

1 Like