Unable to "make" [SOLVED]

I don’t know if is a my problem or a blender problem, please help me. Thank you.

System Information
Operating system: Linux-6.4.8-arch1-1-x86_64-with-glibc2.38 64 Bits, X11 UI
Graphics card: Mesa Intel(R) HD Graphics 5500 (BDW GT2) Intel 4.6 (Core Profile) Mesa 23.1.5

Blender Version
Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-08-09 09:15, hash: 23835a393c80
Worked: (newest version of Blender that worked as expected)

Short description of error
unable to make for some days,

Exact steps for others to reproduce the error
/home/nikkio1/blender-git/lib/linux_x86_64_glibc_228/python/bin/python3.10: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory
make[3]: *** [source/blender/nodes/function/CMakeFiles/bf_nodes_functions_generated.dir/build.make:94: source/blender/nodes/function/register_function_nodes.cc] Error 127
[ 47%] Built target bf_intern_memutil
make[2]: *** [CMakeFiles/Makefile2:7152: source/blender/nodes/function/CMakeFiles/bf_nodes_functions_generated.dir/all] Error 2
make[2]: *** Attesa per i processi non terminati…
[ 47%] Built target bf_intern_opencolorio
[ 48%] Built target bf_intern_ghost
make[1]: *** [Makefile:166: all] Error 2
make: *** [GNUmakefile:368: all] Error 2

I Follow the build instructions exactly as always for about a year.
I’m not deviated, although my girlfriend might disagree…
I can’t find my build.log , in whitch directory is in linux?
Thank you.

@ideasman42 it looks like python3.10 depends on libcrypt.so.1. I guess this got incorrectly picked in the library build.


Thank you very much, you are very kind, I fixed it by installing libxcrypt with this command:
sudo pacman -S core/libxcrypt-compat
(I’m posting it hoping it will be useful to someone)
Thanks again.

1 Like