Unable to build blender 2.90 on Linux Mint

I’ve been trying to build blender the past few days on Linux Mint following the quick setup directions for Ubuntu on the wiki, but I keep running into issues. I cloned the blender repository and then created the lib folder and did “svn checkout https://svn.blender.org/svnroot/bf-blender/trunk/lib/linux_centos7_x86_64” in it, ran the install_deps.sh script. And then I ran make update and make.
Both make and make full give me errors. Here’s the output from make - https://hastebin.com/gexebudika.bash. make lite works, though

Hi, I guess you have problems because you use pre compiled libs and the install script.
The install script help to build the dependencies on your system but this is not needed anymore since 2 month, or so.
I would delete your build directory and start make again, it will find all needed in blender-git/lib/.

Cheers, mib

1 Like

Hi mib2berlin.
I also have a problem, in particular with the linking, see here

I did not use the install script but just followed the steps described here. I downloaded the lib but at the end it ends with errors. Any ideas?

Hi, seams the same problem.
I though all linking problems had been solved, hrm.
I am sorry, a developer has to step by, only builder here.


Juhuu, i have setup a new system with Opensuse and get the same linker errors like you now.


Sorry for tripple post but I have disabled a lot of things now:
Alembic, Openexr, Tbb, Cineon, Jack, for example and these errors left:

[100%] Linking CXX executable ../../bin/blender
/usr/lib64/gcc/x86_64-suse-linux/9/../../../../x86_64-suse-linux/bin/ld: /home/pepo/blender-git/lib/linux_centos7_x86_64/openexr/lib/libIlmImf.a(ImfDwaCompre
ssor.cpp.o): undefined reference to symbol 'compressBound@@ZLIB_1.2.0'
/usr/lib64/gcc/x86_64-suse-linux/9/../../../../x86_64-suse-linux/bin/ld: /lib64/libz.so.1: error adding symbols: DSO missing from command line
collect2: Fehler: ld gab 1 als Ende-Status zurück
make[3]: *** [source/creator/CMakeFiles/blender.dir/build.make:359: bin/blender] Fehler 1
make[2]: *** [CMakeFiles/Makefile2:6551: source/creator/CMakeFiles/blender.dir/all] Fehler 2
make[1]: *** [Makefile:183: all] Fehler 2
make: *** [GNUmakefile:304: all] Fehler 2

Maybe easier to catch now what the problem is.

Attaching the CMakeCache.txt is the most efficient way to figure out what is wrong.

I deleted my previous builds and removed the folder containing blender dependencies at home/src/blender-deps. I can build blender now!! Thanks so much! My mistake was running the install_deps script, apparently.

Hey mib2berlin,

thanks to brecht, I could solve my problem, see here. Greetings.

Thank you, still not working.
I am going to continue in the other thread.

Cheers, mib