Ubuntu20.04 LTS with Quadro RTX 6000 not rendering with GPU

Hi Friends,

I’m a complete beginner here.

Yesterday for testing purpose, I created two separate Linode Dedicated CPU Plans (16GB-RAM + 8Cores & 96GB-RAM + 48Cores), installed Ubuntu 20.04LTS & Blender 2.83 on both of them. And tested rendering speed for one of my animation file. The result was 2 frames & 11 frames per minute respectively.

The terminal command I used was,

blender -b /var/input/sliding_cube_final.blend -o /var/output/frame_##### -E CYCLES -a

Then, I purchased a Linode GPU plan (32GB-RAM + 8Cores + Quadro RTX 6000 GPU), installed Ubuntu 20.04LTS & Blender 2.83 version. I also successfully installed NVIDIA Driver Dependencies, NVIDIA RTX 6000 graphic drivers with CUDA 11.0 version. I confirmed with Linode support team, my graphic drivers were successfully installed. But when the rendering started (same animation file used with CPU plans), the result was only 1 frame per minute.

As far as I know, The blender command used above uses settings (CPU/GPU rendering) from the file. Even after changing the file settings to GPU mode and downgrading to Blender 2.81, the result was same. I’m pretty sure, the Blender wasn’t using RTX 6000 for rendering.

  1. Anybody have similar experience?
  2. Does blender 2.81 & 2.83 doesn’t support RTX 6000?

I would appreciate, if you can provide some help.

Pradnyankur Nikam

Is the following really correct?

  • 16gb + 8 core == 2 frames / minute
  • 32gb + 8 core + GPU == 1 frame / minute

If that really is correct, then the slow 1 frame / minute vm probably isn’t using CPU there as that would not explain why it’s half as slow right? Unless there’s some other difference for the CPU used or similar.

What are the contents of that .blend file? What Tile size is being used? Are things like motion blur or volumetrics being used etc? Can you try rendering that file out locally on your own PC to observe the typical difference between CPU and GPU?

[edit] trimmed some extraneous text until further details emerge

Hi deadpin,

Thanks for the reply. Yes, the frame statistics are correct.

In first case it was “Dedicated CUP plan” while in second it was GPU plan. In both plans they’ve mentioned it as 8 Cores CPU. In GPU plan there was double RAM and GPU, but while rendering, it was actually rendering slower. I’m not sure if they are using the same CPU for both plan, they haven’t mentioned about it.

  1. I’ve attached a frame of my animation file, so that you get an idea about content of the file.
  2. Tiles size 64x64px
  3. Haven’t used any effects.
  4. The result on local computer are as following,
    AMD FX 8350 + 8gb RAM => 1 frame per minute
    AMD FX 8350 + 8gb RAM + GTX750Ti => 3 frames per minute
    i3 6th Gen + 16gb RAM + GTX750Ti => 3 frames per minute
    The CPU plan worked as expected but I believe, there was some problem with GPU plan, even I installed the drivers properly.

This is a forum for Blender development, for help using Blender there are the community websites.

Note that GPU rendering must be enabled in the preferences, which you would usually do with a script on servers like this. Further, you can run blender with --debug-cycles to get information on which devices Cycles is actually using.