Ubuntu 22.04 LTS - [ALSOFT] (EE) Failed to set real-time priority ... Blender crashes

Hey Friends,

I run into problems to compile the latest version of Blender at my Ubuntu 22.04 LTS VM. It compiles fine, but Blender then simply refuses to start and throws a audio related error which i am not sure what to do with. Previous versions of Blender compiled just fine at the same VM.

I have then grabbed a backup of the blank Ubuntu VM to make sure it is not my current Ubuntu installation, updated it to the latest changes, with an installed Cuda 12.1 as required* by Blender nowadays, and compiled Blender there. With the same result. Means it must be something more general.

  • Ubuntu 22.04 LTS doesn’t really like Cuda 12. It randomly crashes with it, at resizing Nautilus for example. A report to Ubuntu was declined. They think Nvidia should fix it. But besides that everything seems to work. And compiling and starting Blender worked until today. So i guess Cuda 12 has nothing to do with it. The build is just compiled with make anyways and so without cuda. But who knows.

Either way, last week starting a compiled Blender still worked, but now starting newest Blender version is impossible. It crashes with the error.

[ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1)

And the blender.crash.txt is not really informative as you can see. At least i found out that ALSOFT is the audio driver.

Any idea what i need to do to get Blender to start at Ubuntu again? Any help or advice is highly welcome :slight_smile:

Kind regards Arunderan

The crash and the audio warning are likely unrelated, you can try building without WITH_AUDASPACE to rule out an audio issue. beyond that load it up into GDB and see what that says about the crash

Okay, will try, thank you :slight_smile:

This is what i get.

Just wanted to add, i downloaded the actual 4.0.0 alpha linux build from builder.blender.org now, and it crashes the same way.

The stack there is similar to #110335 - crash on startup, blender 4.0, macos 12, Intel Iris Graphics 6100 - blender - Blender Projects

4.0 will require a minimum of OpenGL 4.3 support. Does your GPU/driver combination support that?

Many thanks deadpin, this could explain it. glxinfo indeed tells me that my OpenGL version is 4.1.

Well it is a VMWare VM with a vanilla Ubuntu 22.04 LTS. And there is very little settings that i can adjust in the VM settings. Basically just accellerate 3d graphics. The card itself is emulated without any further informations. VMware is already the actual version 17. It’s the free player version. But the player itself supports version 4.3, that’s at least what the release note tells me. So Ubuntu seems to be the trouble maker here.

It would be sad when it would be not longer possible to use Blender in a Ubuntu 22.04 VMWare VM. It’s the long term version, appeared in April 21, 2022. So we had a very short liftetime of a bit more than a year here.

Blender 3.6 LTS will be supported until June 2025 so that is a good path forward if you must run inside VMs.

Beyond that, you can attempt to update the Mesa drivers beyond what 22.04 ships with and see if that helps. But that’s off topic for this forum and discussion around that can better happen in the various User Community links above.

Many thanks for the info deadpin. Maybe the hint with the mesa drivers will lead me to somewhere.

EDIT, no luck. Still 4.1. Time to let go i guess.