Trying to Build Blender but getting Cmakr Error

System Information
Operating system: Ubuntu 19.04
Cmake Version: 3.13.4

Blender Version
Broken: Honestly have no idea.
Using visual studio latest version.
followed the build blender wiki using pre-compiled libs.

** Error **

Configuring Blender in "/home/ashwin/Documents/GSOC/Blender/build_linux" ...
-- Using pre-compiled LIBDIR: /home/ashwin/Documents/GSOC/Blender/blender/../lib/linux_centos7_x86_64
-- Could NOT find Jack (missing: JACK_LIBRARY JACK_INCLUDE_DIR) 
CMake Warning at /usr/share/cmake-3.13/Modules/FindBoost.cmake:880 (message):
  New Boost version may have incorrect or missing dependencies and imported
Call Stack (most recent call first):
  /usr/share/cmake-3.13/Modules/FindBoost.cmake:1002 (_Boost_COMPONENT_DEPENDENCIES)
  /usr/share/cmake-3.13/Modules/FindBoost.cmake:1670 (_Boost_MISSING_DEPENDENCIES)
  build_files/cmake/platform/platform_unix.cmake:324 (find_package)
  CMakeLists.txt:801 (include)

-- Boost version: 1.70.0
-- Found the following Boost libraries:
--   filesystem
--   regex
--   thread
--   date_time
--   wave
--   locale
--   iostreams
--   system
--   chrono
--   atomic
--   serialization
CMake Error at build_files/cmake/platform/platform_unix.cmake:417 (if):
  if given arguments:

    "WITH_OPENCOLLADA" "AND" "(" "VERSION_LESS" "4.0.0" ")"

  Unknown arguments specified
Call Stack (most recent call first):
  CMakeLists.txt:801 (include)

-- Configuring incomplete, errors occurred!
See also "/home/ashwin/Documents/GSOC/Blender/build_linux/CMakeFiles/CMakeOutput.log".
See also "/home/ashwin/Documents/GSOC/Blender/build_linux/CMakeFiles/CMakeError.log".
make: *** [GNUmakefile:312: all] Error 1

try if(WITH_OPENCOLLADA AND ("${LLVM_VERSION}" VERSION_LESS "4.0.0")) at build_files/cmake/platform/platform_unix.cmake:417


for silencing those warnings, one can turn OFF boost, if not required


This worked but then I encountered a new error after that while linking cxx executable. the error is too big to post here but what I understood by it is cmake isn’t recognising any function or variables in script being executed, Its showing lots of error:undefined reference to …
Please help

Paste on

almost every library is giving errors… Why don’t you try Cmake’s latest version ?

1 Like

Even after updating cmake it’s giving the same error :zipper_mouth_face:

Precompiled libraries for Linux, aren’t yet very stable. It requires some manual patching to the patch itself. You may have better luck when combining running make deps and The adds the missing libraries to opt/libs, but some may fail like ilmbase (download longer exists), if that happens, you can use make deps, and copy some of those libraries to opt/libs.

1 Like

Hi, I run into the same problems with the prebuild libraries but got it to build with some tweaking.
Here is the tread with some steps we try: Linking errors with prebuild libs on Linux
There is a patch in the works but not finished atm.
I had a working build system with mixed libraries from make deps script, system and self build libs but is really a mess and not comparable to the release builds or build bot builds.

CHeers, mib

1 Like

Since I was unable to build blender on ubuntu I built it on windows :slight_smile:

Hi, when do you try on Linux?
It is all fixed now in master with the prebuild libraries, delete the the build_linux directory to make sure all is clean.

Cheers, mib