Transparent BSDF Color

The ‘Transparent BSDF’ shader node does not reflect (as in diffuse reflection) any light, meaning that it always renders as a black surface regardless of the value provided in the color parameter, all that parameter does is control the alpha/transparency of the surface, not it’s color (as the name would imply).
I modified a local version to fix that behavior by adding a new input to the node (called ‘Alpha’, like the principled bsdf node) that now controls the transparency of the surface, and ‘Color’ now is the color of the surface.

This is the main change, the rest is just boilerplate stuff to support the new parameter.

result.radiance = color.rgb * alpha; // previously: vec3(0.0);
result.transmittance = vec3(1.0 - alpha); // prev: abs(color.rgb);

This would be my first contribution to blender so I’m not too sure how you prefer I set this up. Is there something I should know before I create a ‘patch’ for this ? Should I create a new type of node since this could be thought of as a breaking change ? Would you prefer I leave this to another maintainer ?

Hi @Eideren ,try having a look here[]
hope it helps.

The contributing code link indeed explains how best to contribute this.

But this particular change is not something we want to do. The transparent BSDF should not emit any light (as your patch would do), it should only add transparency and nothing else. The purpose of having a color there is so you can e.g. let through only red colors from objects behind.

If you want an object to both emit light and have transparency, you need to use an Emission node and Transparent BSDF. Or just use a Principled BSDF and disable everything except Emission and Alpha.