The Video Sequence Editor - Reworked (a ready to patch suggestion)

Nice find! I went ahead and committed the change since it’s pretty harmless and a much better use of space. Thanks!


what does it look like when you have the numbers in the corners now?..
UPDATE: no worries i looks good.

A fix that would be great, when you are on the video editor if you use up and down arrows, the play head should go to the previous (up), next (down) edit that is close in the timeline, when youre hoveing your mouse over the VSE editor :slight_smile:

The latest functions in the menu:

I would like to add the Ctrl+mouse click and drag snapping function, but I simply can’t find an operator to call from the menu? Anyone knows what the operator is?

@pablovazquez Now you got your hands dirty in the strips code, how about just using the filename(not full path) centered on the strips? And maybe have the texts in a bit more subtle color(maybe dark grey instead of pitch black)? The texts look very messy and dominating as they are right now(but that’s just my opinion :wink:) .

Here are some ss of the changes in the VSE menus in the VSE - REWORKED suggestion.

I’ve been trying to expose as many hidden functions as possible without cluttering the menus. I hope there will be added more “Edit” and “Navigation” functions.

One of the main changes is that the strip menu has been converted into 3. menus.

  1. Edit: for all repeated operations relating to the editing of selected strips. (Additional functions planned)
  2. Transform: for all repeated operations relating to the movement of strips. (Additional functions planned)
  3. Strip: for all single operations relating to the what the strip is containing.

A few more options(ex. Backdrop added to menu) has been added and the strings has been shortened:

Bundled and added new functions into Cursor, Handle, Channel. Locked and Muted/Hidden should have been added to grouped, but that menu seems not to be coded in python(and it needs proper shortcuts).

Changed the name to something more meaningful but still in consistency with Blender naming. (All the jump to functions may go into a “Jump to” sub-menu. (Additional functions planned)

New functions added to the menu:

  • Select Strips Under Cursor
  • Select All Strips in Selected Channel
  • Select Locked Strips
  • Select Muted/Hidden Strips
  • Cut > Extract (Ripple Delete)
  • Toggle All Modifiers On/Off
  • Toggle Audio Icon-Button in Header
  • Show Waveform in Selected
  • Set Preview Start
  • Set Preview End
  • Set Preview Selected
  • Split & Lift Left
  • Split & Lift Right

Existing functions added to menu:

  • Select Time Code Style
  • Render/Downmix Audio
  • Rearranged the menus in the order the user will need them. Except “View” and “Select” because of consistency.
  • Divided them into shorter menus.
  • Toggle Meta Strips
  • Un-Mute/Un-Hide Deselected
  • Jump to Keyframe/Start/End)
  • Zoom Border…
  • Flip X/Y
  • Reverse

Wow, that’s just so impressive. Already implemented and out in the next Blender build!

Maybe I can ask you about two (I hope minor) things:

The VSE export times are very high, could you check if adding to the internal ffmpeg command line switches…
-threads 0
…will make a difference?
The switch should set the ffmpeg to use all cores(as Blender exports now it is only using one core).

The other thing is blocking proper left-click to work in the VSE, can you see a quick fix for this one too?

Anyone else, it would be great to get some feedback on the menus above, or else I’ll conclude that everything is perfect as it is. :wink:


Well, no need to include things like play/pause in the menus - those things are for the whole of Blender, not specifically the sequencer.

Also, in Blender consistency is important. Try and use the same names for things as in the other Editors. For example, the Home key does ‘Frame All’ in the 3D View, but ‘All Sequences’ in the Seqencer, even though it’s the same feature.

We must use the same terminology everywhere.

1 Like

I’m not very well versed in the functions outside the VSE, so it is going to take me ages, to find out what functions mirrors what functions in the rest of Blender. If the standard naming in the VSE isn’t even in consistency with the rest of Blender… Anyone up for this challenge?

It should be simple enough - just open any of the other Editors, such as 3D View and look in those menus.

How does this work for you?

For me, it would be more understandable to have:
“Frame All” > “All”
“Frame Selected” > “Selected”
“Frame” > “Cursor”

Because it is like the name of the menu becomes the first word of a sentence. Ex. View > All as compared to View > Frame All.

And using the word frame to frame a frame becomes confusing. And it is not any frame you want to view, it is the frame at the cursor, you want to see.

I’ve added the word “Image” to the Viewport Render Image", because I fear new generations will not understand the icon.

On the play button - in the 3D View it is located in the View menu, but having a Navigation menu in the VSE, that would be the logical place to have it imo. I hope we’ll be able to add more playback controls like increasing/decreasing speed, so I hope there will be more entries in this menu.

Anyways, you can have it the way you prefer, just let me know.

We have started to add feature suggestions here:
If there are any of those you don’t want to see implemented in this suggestion, please let us know.

We should include the word ‘frame’ in Frame Selected. View > Selected doesn’t provide enough information.

The main point is that we should use consistent terminology.

In the Select menu in the 3D View the word select is used in all entries except 3.

What are the thoughts about this choice(just trying to understand)?

In that case, yes, the word Select is redundant. But in your case, the menu is not called ‘Frame’, so it should say ‘Frame All’.

Ok. Any thoughts on this stuff?

I don’t get the first point. ‘Frame’ here is used as a verb.

‘Viewport Render Image’ is indeed better than ‘Viewport Render’. We should fix this in the 3D View too.

Re. Play: I think we should remove this from all the editors. It’s not a view setting - it’s just playback, and you can see the hotkey if you read the tooltip on the play button.

The main thing is just consistency above all. If we change the name of something, we should do it globally, not differently for different Editors.


1 Like

What about “Frame Playhead” instead of “Frame Frame”?

1 Like

Center Cursor - is maybe better - because it seems that this is what actually is happening when using this function?

Yes, we should call this the playhead.

Well, I think it’s confusing to call the playhead the ‘cursor’. Better to just call it what it is I think.

It has been referred to as “Time Cursor” pretty consistent:“time+cursor”&oq=Blender+“time+cursor”