[Solved] One tiny problem during building of 2.82

Scanning dependencies of target blender
make[3]: *** No rule to make target '/usr/lib/x86_64-linux-gnu/libgomp.so', needed by 'bin/blender'.  Stop.
make[3]: *** Waiting for unfinished jobs....
[100%] Building C object source/creator/CMakeFiles/blender.dir/buildinfo.c.o
make[2]: *** [CMakeFiles/Makefile2:8106: source/creator/CMakeFiles/blender.dir/all] Error 2
make[1]: *** [Makefile:163: all] Error 2
make: *** [GNUmakefile:313: all] Error 2

Have anyone else encountered this? I’ve tried reinstalling the dependencies again. And it must also be said that I recently upgraded to Ubuntu 19.10 from 18.04 because i read about the performance boost in general…

Error 2 message is just indicating that something went wrong.
But that is Error 1 message that is indicating the culprit.

ah, okay, I’ll leave those out next time… :slight_smile:
The problem for me though is that libgomp1 is installed, and I’m not sure why it can’t find it… There is no libgomp1-dev file to install either, so i’m a bit confused…
i have checked the folder it mentions, but the only file i can find there is libgomp.so.1… Can I force blender to recognize that one?

try installing libomp5 and libomp-dev and see if that helps :slight_smile:

Actually, I figured out that i could just change the reference to the file inside the CmakeCache.txt file. It accepted it without further hiccups. All is well now. :slight_smile: Thanks for the help offered in any case. :slight_smile:

1 Like

Great :slight_smile: