SOLVED: Geometry Nodes Add Menu Blank/Empty

In my own compiled version of 2.92 Alpha, the Add Menu (SHIFT + A) is empty for the Geometry Node Editor, but if I download a precompiled daily build the add menu has all the Nodes: Attribute, Color, Geometry…

I get errors in the console like:
…\2.92\scripts\startup\bl_ui\space_userpref.py:2158
rna_uiItemR: property not found: PreferencesExperimental.use_new_point_cloud_type

…\2.92\scripts\startup\bl_ui\space_userpref.py:2158
rna_uiItemR: property not found: PreferencesExperimental.use_new_geometry_nodes

Ideas for how to get the Add Menu working in my own build?

Okay, I was compiling just from Visual Studio (target: Blender), so I went and did a Make from the command line now I’m getting all the Nodes to add and no errors in the console. I probably could have fixed it by doing a complete build in Visual Studio too.

Should I delete this thread? Or mark it as solved?

Yes, if you want to run blender from within Visual Studio, you have to build the INSTALL target first.
Just search INSTALL in the solution Explorer => right click => build.
That should do the trick for the missing nodes in the add menu. :slight_smile: