[SOLVED] Building successfully but "Shade Auto Smooth" was broken in Cycles

Hi. I compiled my Blender successfully, but when I shade the object with “Auto Smooth” in Cycles, the object will become strange. It is fine in official Blender, but not in my Blender.

My steps:

  1. Install:

Visual Studio Build Tools 2022: 17.6.1

MSVC: v143 (14.36.32532)

Windows SDK: 10.0.20348.0

Git: 2.38.1.windows.1

SVN: 1.14.2-SlikSvn

CMake: 3.26.1

Python: 3.11.0

Windows: Windows 10 22H2 19045.2311

cd D:\blender-git

git clone https://projects.blender.org/blender/blender.git

cd D:\blender-git\blender

git checkout blender-v3.5-release

cd D:\blender-git\lib

svn checkout https://svn.blender.org/svnroot/bf-blender/trunk/lib/win64_vc15

cd D:\blender-git\blender

make update 2022b

This step is always failed, because the Python in the “lib/win64_vc15” is running (I don’t know why).

So I copy the “lib/win64_vc15/Python” to “lib/Python”, and modify the make.bat:


call "%BLENDER_DIR%\build_files\windows\find_dependencies.cmd"

if errorlevel 1 goto EOF

+ set "PYTHON=D:\blender-git\lib\python\310\bin\python.exe"


Add a line to force use the Python outside “lib/win64_vc15”.

Rerun make update 2022b.

At this time, update to lib is success.

But update to source is skipped: “Blender repository skipped: you have unstaged changes”.

And then I restore the “make.bat” file.

Rerun make update 2022b.

At this time, update to lib is “skipped”(it is ok, because it is already up to date),

and update to source is success.

By the way, I have try make fixsvn or make fixsvn 2022b, and it always output this:

No explicit msvc version requested, autodetecting version.

Compiler Detection failed. Use verbose switch for more information.

Visual Studio not found (try with the 'verbose' switch for more information)

cd D:\blender-git\blender

make release nobuild 2022b

cd D:\blender-git\build_windows_Release_x64_vc17_Release


I haven’t made any modifications to the soruce code. It builds successfully.

  1. Open the Blender in D:\blender-git\build_windows_Release_x64_vc17_Release\bin\Release\blender.exe

  2. Select the “Cube” and right click and select “Shade Auto Smooth”.

  3. Switch to “Viewport Shading” mode, switch the “Render Engine” to “Cycles”, switch the “Device” to “CPU”(“GPU” is same), and you can see the cube look strange. After changes some properties, the “shape” of the Cube will change randomly.

I try to install CUDA Toolkit and Optix SDK, and finally it builds successfully, but the problem has not been solved.

It just happen in Cycles, not EEVEE.

so… Did i compile it wrong somehow?

because I am the new user, I can’t post the log file…

The problem has been solved.

I try to build the Blender with Visual Studio Build Tools 2019, not 2022, and then the “Shade Auto Smooth” works fine.

By the way, you must install MSVC v142 (2019) by the Visual Studio Build Tools 2019, not Visual Studio Build Tools 2022.

If not, make.bat will not find the MSVC v142 (2019).

So it seem that, currently you shoud not build the Blender with Visual Studio Build Tools 2022.

1 Like