Setting a custom script path in the preferences doesnt seem to work?

this is my setup:

full path to addon:

E:\blender\shared files between versions\scripts\addons\Screencast-Keys-master\

not listed after restarting blender:

That looks like, another, common problem I see pop up over and over in many other places – did you just copy the github repo of that addon?

If so, that’s not going to work; the directory structure in git is different than the directory structure of a proper addon.

You can try to set a BLENDER_USER_SCRIPTS environment variable - works for me.

1 Like

you hit the nail on the head, the problem was between the chair and the keyboard :smiley: Thanks for your help.

thanks, sorted though, it was my fault. I was copying the github root instead of the source folder.

It seems you got it working, but Blender’s way of dealing with file paths in general is a bit… interesting…

It has some design ideas that limit things like Project Managers as in Maya or Houdini to be a very hard to add as a addon or alike.

And just a note here… Try to avoid long foldernames, especially with spaces. Use a _ if neccessary.
Unless the filepath was a example :wink:

Hi Jim,

How does one define this in a init startup file, like with Maya’s or Houdini’s .env file?
I have a set of custom application templates running, and if I can add this to the script, it would already make my life a bit simpler :wink:
Or even better, use all the File Paths variables for a init startup script.


edit: with the help of the code inside the preferences menu and the application template example I got it to work just fine. It was just getting the proper context in the init file.

In review I’m not sure I understood the question, nor realized purpose of the forum. I’m new to Blender and wanted to get started with Python scripting. I found myself loading Blender defaults a lot and wanted to not have to set the Scripts file path every time I reset. I found that by setting the BLENDER_USER_SCRIPTS operating system environment variable my test scripts and addons where available no matter which version (stable or nightly) of Blender I opened.

This is the conclusion: If you have a addon zip, the way to install this addon to your custom folder consists of 4 steps:

  1. Install this addon in Blender Perferences window

    You will see it install in C:\, for me it is C:\Users\UserName\AppData\Roaming\Blender Foundation\Blender\3.4\scripts\addons

  2. Set environment variables BLENDER_USER_SCRIPTS = <Your Custom Path>

  3. Cut and paste your addon folder in C:\ to <Your Custom Path>\addons\

  4. Restart Blender and you will see your addon location is right in your custom path and it can be activated without errors like Don't find module xxx

I haven’t tried the environment variable way (I just set it in the Blender preferences), but have you tried just unzipping the addon to your custom folder? That’s all I do, and it automatically shows up in the available addons when refresh. Then it’s just a case of enabling it with the checkbox.