Setting a custom script path in the preferences doesnt seem to work?

Can someone help me with the custom script path. I’ve entered my custom path in the preferences, and ensured it has the same folder structure as the script folder in the blender directory. After restarting I still don’t see the addon listed that I have in my custom addons folder.

Is this broken or am I a lunatic? Or perhaps both :slight_smile:

I’m a bit confused about why it needs the same folder structure as well, does this mean that contents of the non addon folders in my custom path will be used instead of the non addon folders in the daily builds I’m using? That would be a bit rubbish as my custom folder would become out of date next time I download a newer daily build.

I was expecting to just specify a custom addons folder, in which I could put non bundled addons, so that I would be responsible for updating my purchased addons, whilst blender would still use the latest version of the bundled addons from the daily build folder.

If the addon is just a script named “something”.py, it will not work.
Create at least a folder per script/addon if this is the case, and rename it to

Now it should show up in the Preferences as a addon. It’s a hack, it’s better to properly create the addon setup.

e.g. You made a folder setup called ‘WG_Blender/addons’. (WG=workgroup, we have many…)
Now create a folder named “something” in there.
Copy the script in folder ‘something’, and rename the .py file.

So you end up with 'WG_Blender/addons/something/__ init
Inside the File Path/scripts you reference to the ‘WG_Blender/’ folder.

With ‘regular’ addons, just install the addon in your user folders first, and then move it to the external ‘addons’ folder. Restart Blender so you don’t get double entries.

If it’s something else, I’ve no idea, but it works here like this. :wink:

edit: made the folder structure more clear…

It’s actually the screencast keys addon, mesh machine, hardops, box cutter, etc.

You have to install it to your user folder first? That’s weird, what’s the point in having a custom script folder then?

I was hoping to put my non bundled addons in my custom folder so I don’t have to copy my addons back into my daily build addons folder each time I download a new daily build with a different point release.

If you have the same file names in both locations which one does blender use if they’re not identical by file size/creation date?

Are you following the layout required in the manual:

Namely something like [custom path]/addons/[box cutter folder etc.]

It works for me when I try here:
User Prefs: Scripts = C:\Users\___\Desktop\test\
Example: C:\Users\___\Desktop\test\addons\modifier_list

In some cases, just unzipping a addon to folder X will not work.
So I normally install the addon first as it ‘should’, and move it to my custom addon folder after that.
Reboot Blender, and it works.

I’m running the same setup as you, having all my addons separate from my Blender installs.
It works over here, so you must be doing something wrong.

I slightly changed my folders example in the previous post to make it more clear. Sorry about that…

yup, I think it’s because I’m not also putting it in the C:\Users\3diWorkstation\AppData\Roaming\Blender Foundation\Blender\2.90\scripts\addons folder.

My understanding of it’s purpose must have been wrong…although i’m not entirely sure what it’s purpose is if you still need to have it the appdata folder as well.

yep, I was expecting it to just read the addon from the custom location, not realising I had to have it in two locations. It’s a rather oddly designed idea :slight_smile:

Using the AppData folder is unnecessary though. See my example above where I tried out using my Desktop folder as a test.

when you install it I think it automatically puts it into the app data folder, unless there’s a third place it saves them to :smiley:

So basically it wont work unless you install the plugin (which unzips it to the app data folder) or manually place it in the two locations mentioned, the custom folder and the app data folder.

Well, unless you unzip the folder into the daily builds addon folder, in which case it installs it automatically when you open blender, and also places it in the app data folder automatically.

Sure, yes, you need to “Enable” the addon still. But that doesn’t modify the AppData folder here - have you checked?

yep, just checked and my addons have been unzipped by blender into the app data folder for 2.8 upwards. In those instances I’d copied the addon to the downloaded daily build’s addon folder, and blender had added them to the addon list (not installed sorry), and also copied them to the app data folder.

I was speaking to the design connected team a few months ago when they’d just released their asset manager addon for blender. They were also extremely confused with this behaviour, unsure where to put what.

Yes, that’s what happens when you “Install” from a .zip – it will be unzipped into the AppData folder (not the custom script folder)

I guess that’s where the confusion lies. The custom script folder is for already unzipped addons.

When using custom script paths you do not “Install”, you just “Enable” since the custom script folder is more the “search path” (per the docs: An additional location to search for Python scripts.) and not an “install files here” or “automatically install zips from this location when launched”

yep, but I don’t want to install it from a zip, I want it to place it in the custom addon folder and it just appear in the preferences addon list, otherwise what’s the point in the custom location if you’ve still got to install it to another location or manually place the unzipped folder into two locations? Makes no sense to me.

If it listed it in the addons and then automatically copied it to the app data folder, the same as it does if you use the daily builds addon folder, then that would be halfway to a better system I guess…but I’m still not sure why it needs to unzip the same folder to the app data folder if that identical folder is already sat there in the custom folder.

??? You don’t? I didn’t have to with the addon I tried above.

Here’s what I did:

  • I unzipped an addon to c:\users___\Desktop\tests\addons\ called modifier_list (it will remain here forever now; this is the only time you have to perform this step)
  • I set blender to use c:\users___\Desktop\test\ as a custom script path
  • I re-opened blender and immediately just “Enabled” addon modifier_list (it did not get copied to AppData)

Weird, that’s what I’ve done and the addon in the custom folder aren’t appearing in the addon list.

unless it’s a bug with 2.9? Have you tried it with 2.9?

edit: just saw 2.9 in your file path.

stumped then.

Unless there is a third location that it gets saved to. Maybe you’ve used that addon in a previous version number, so it’s in an additional location blender checks for addons.

Could you try downloading some addon you’ve definitely never used before, unzip it into your new custom folder, and then see if it appears in the addons list when you restart blender?

maybe try putting the custom folder on a different drive too, although I can’t imagine that should matter.