Pressing Alt deactivates keyboard shortcuts

When pressing Alt in the 3D viewport and just releasing it without doing anything Blender shows a hint of available shortcuts in the bottom row of the interface. As long as this is shown, all the shortcuts not listed are unavailable.

This behaviour is confusing and feels punishing when e.g. pressing Alt for a certain shortcut and then decide to do something else instead and nothing seems to work anymore.


  • Do not disable unlisted shortcuts
  • Show this function in the preferences/keymap so it can be disabled or relocated manually

This is leader key / toolbar prompt functionality. It was added to defaults in 2.82 and will be disabled by default in 2.90.

If you want to it disable right now search for “wm.toolbar_prompt” in the input editor and uncheck it:


1 Like

Thanks a lot!
It’s not showing up when searching for Alt or left/right Alt key-bindings. There is no way I would have found that.
It’s also good news that this behaviour is changed in future versions.