Poor naming of "Purge All" operator

In a typical Blender fashion, we need to have ridiculously “creative” names for everything. One example is Purge All operator. Purge is a word rarely used in computer graphics. As a rule of thumb, if someone asks you what X means, and you do not use X as a part of first two sentences, then it’s really poor name.

Practical example here:
What does “Purge All” mean? (Extremely ambiguous name, which does NOT describe what the feature actually does, so it could mean purge memory, purge scene objects, purge blender install?, or perhaps format C: drive?)

Answer: Purge all removes all unused data from blender file.

Operators should be named after what they do, not for the author of the name to show off his linguistic creativity. Rename the Purge All operator to “Remove Unused Data” or “Clear Unused Data”.

Even the tooltip itself admits “purge” is not the right description, omitting the word: