OPTIX location not found since moving to 7.3.0 on Windows

Maybe I’m the only one having this, but since the OPTIX requirement has been bumped to 7.3.0 (with Blender 2.9x I believe) the usual make release calls fail to find the source path of OPTIX. When we were still at 7.2.0 this worked on my system just fine. Error message is:

Could NOT find OptiX (missing: OPTIX_INCLUDE_DIR) (Required is at least version “7.3.0”)

It is clearly installed on my system at default location, when I later on edit CMakeCache.txt in the root path of the build directory I can use it and build successfully. I just wonder why in the initial project configuration fails to locate it all of a sudden.

I also tried defining an OPTIX_INCLUDE_DIR environment variable pointing to C:\ProgramData\NVIDIA Corporation\OptiX SDK 7.3.0 but this doesn’t work either.

I actually found what needs to be changed for the detection to work. There seems to be an outdated version number in the FindOptix.cmake located in build_files/cmake/modules. In the Blender sources it still points to OptiX SDK 7.0.0. Change this to:

SET(_optix_SEARCH_DIRS
${OPTIX_ROOT_DIR}
“$ENV{PROGRAMDATA}/NVIDIA Corporation/OptiX SDK 7.3.0”
)

and the binaries will be found again.

1 Like

I updated the OPTIX_ROOT_DIR in FindOptix.cmake now, thanks for pointing this out.

3 Likes