NUMPY problem with my build, please HELP!

HI there.

I do my own build using instructions from the wiki, but now I need to export to GLTF but I get a loooong error, but I think the key of the error is here:

Something seems to be weird with the default numpy included with Blender libraries, but if I download the daily build from teh website everything works correctly.

How can I fix this?


Ok, I’ve checked my Cmake settings and everything seems to be correct, Python 3.7 and numpy updated to the latest version, I’m on Linux Mint BTW.

Here are my Cmake settings related to Numpy:

Some help welcome, I would like to have a fully functional build :slight_smile:

Best regards

Googling for similar error message show issues with broken numpy installations. You could try running python3 -c "import numpy" on the command line to see if it’s working at all.

Deleting the numpy installation and installing it again may help. It’s a bit tricky because it can be installed for python 2 or 3, or different versions of python 3, or through the package manager or pip.

1 Like

Thanks Bretch!

I’ll try it :slight_smile:

Thanks Bretch.

I investigated and finally I found a way to solve it.

First of all I had to make sure that I had Python3.7 installed, after that I used Pip3.7 to install Numpy, and I was still getting the error.

The problem was that after installing python and Numpy I had to go an clean all the Cmake cache and reconfigure and regenerate the project, after I did this it seems everything is working!

Thanks again!

Tried with the distro numpy too?
The issue probably was the cached build, as it does not seem to detect all kind of changes… but pip if distro can do it…

Yes, I’m the end probably the solution could have been to just install python 3.7 from apt and then install numpy with it, then delete the build,cache and remake it, and everything should have been solved.
But since I didn´t knew the culprit I tried a lot of things, installed different python and numpy versions… etc… I made kind of a mess LOL

But now everything is working :slight_smile:

Thanks for the suggestion thought @gsrb3d