Node editor zoom sensitivity is way too low

To zoom in on a node by holding middle mouse and pushing forward with the mouse, I have to push the mouse approximately half a kilometre. Seriously though, I have to pick my mouse up off of the table and bring it back in the air before resuming because my desk/arm length cant facilitate a single push, and for those wondering, no, I’m not physically reminiscent of a Tyrannosaurus Rex.


Separate zoom options for node editors, with the additional option of custom zoom sensitivity. It would also be nice to have the option to swap the node editor to zoom by moving the mouse horizontally rather than forward and backwards (like it used to be in 2.79)

This should be fixed after:

1 Like