Need CUDA help for Windows build


#1

Bit of a newbie to Blender dev and the Windows build. But I did some searching and didn’t find an answer.

I have CUDA 10 installed. Got Blender 2.8 building for the first time today but it doesn’t see any of my Nvidia GPUs. The downloaded daily build works fine (recognizes more GPUs than I knew I had).

I installed CUDA 9.1 as well. Built Blender again. Still no luck.

Not sure if I need to clean up and rerun CMake or something. Or if I need to play games with my Path or other environment variables to make this work.

Before I try all possible permutations of paths, env variables, etc… (my usual experience with Windows) perhaps someone can suggest the magic combo. (It would also be nice if it didn’t cause all of my existing CUDA 10 and Vulkan code to break either ;-).

Thx,
~chuck


#2

I don’t think it will work with CUDA 10, you may just need to juggle paths or set some build option to ensure it finds 9.1.

When I set up the Windows build using the WIKI instructions, I found that “make full” did not build the CUDA support and I had to do “make release” in order for my GPU to show up in the System Preferences so try that if you haven’t.

Good luck. It’s really nice to be able to build the latest whenever you want to, and it’s quite fast as long as it doesn’t need to rebuild the CUDA kernels which takes like 20 minutes.