Missing addons in Blender 2.8


#1

Hi there,

I build Blender by myself, I m a windows 7 user building with cmake and Visual Studio 2017 , yesterday i noticed that i could see only 2 addons in the addon tab, all other addons are missing,

and hash is missing too.


But in Blender build from builder.blender.org all addons are there

and hash number as well

This is what i have done so far to troubleshoot the problem:

  1. Updated all libs

  2. Updated all dependencies ( cmake and git )

  3. Removed the whole blender-git folder (place the build happens), still the problem is acquiring.

Is there any setting that i need to change to have those missing parts back?

Thanks in advanced :slight_smile:


#2

After discussion with Lazydodo :slight_smile: in irc, we finally solved this problem. The problem was my way of updating my C:/…/ blender folder was not appropriated when git head was pointed Blender2.8
Since i have been following tutorial from https://blog.machinimatrix.org/building-blender/ and there, the update is git submodule foreach --recursive git pull --rebase origin master

The solution was to reinstall git and make sure that git from the command line and also from 3rd-party software (the option in the red square) was checked and other settings default that solved the problem. gitpath


#3

Just to clarify, our documentation included the mention of having both git and cmake in your path, and recommend updating with make update which would have prevented any of the issues you are experiencing from happening.

I’m ok with people winging it, or following other directions, but support on those kinds of endeavors is going to be very limited.