Right now, the Math and Vector Math nodes adapt their title to their current operation name. For example, the Subtract operation:
Even though this is a Subtract operation selected from the dropdown of a Vector Math node, this node title implies that the actual node is a Subtract node which does not exist. For consistency, a node should really say its own name, not change with the values in the node. This is also redundant because it says the operation selection twice, right above and below each other. This also makes it harder to tell from a glance whether, for example, “Subtract” refers to vector math or scalar math because it doesn’t say the node type.
I would propose removing the dynamic title and keeping the actual node name consistent so it isn’t so funky.