"make update" error, Access denied


I usually build Blender regularly, but since a day or two I have this error saying that it does not have access to move a file, but I didn’t change anything on my side, is there something I should change to make it work ?

Cheers !

> ./make update
No explicit msvc version requested, autodetecting version.
** Visual Studio 2019 Developer Command Prompt v16.4.4
** Copyright (c) 2019 Microsoft Corporation
[vcvarsall.bat] Environment initialized for: 'x64'
Compiler Detection successful, detected VS2019

Updating Precompiled Libraries and Tests

D:\softwares\TortoiseSVN\bin\svn.exe --non-interactive cleanup D:/prog/blender_git/blender\..\lib\win64_vc15
svn: E155009: Failed to run the WC DB work queue associated with 'D:\prog\blender_git\lib\win64_vc15', work item 36370 (file-install python/37/DLLs/_lzma.pyd 1 0 1 1)
svn: E720005: Can't move 'D:\prog\blender_git\lib\win64_vc15\.svn\tmp\svn-23A635BC' to 'D:\prog\blender_git\lib\win64_vc15\python\37\DLLs\_lzma.pyd': Access is denied.

Had the same problem yesterday. I manually deleted the \lib\win64_vc15\python folder, ran "svn cleanup %path_to_the_lib_directory% and after that make update worked again.
I hope this helps.

1 Like

Oh sorry I didn’t see this post :confused:

Was the same here. Didn’t change anything on my end ,but ran into this issue. Doing a cleanup and then update fixed it.

Had this earlier today, but command line svn cleanup wasn’t working. Kept giving me “blablabla is not a working copy directory”

What worked is right-click context menu for the folder. TortoiseSVN->Cleanup

I got same issue. After I change branch to master, then make update.

I tried svn clean up with tortoice svn (right click context menu), and clean up suceed, but it did not work when I “make update” , I still see same access error.

but as you said, delete python directory >>svn clean up >>make upate
finally worked for me. thanks!!