Not getting very far building blender for Linux. This is POP-OS which is supposed to be an Ubuntu derivative but apparently is not that exactly…

I tried to build with system libraries, but libshaderc-dev was missing. It is complaining about this. So then I tried the instructions for downloading all the precompiled ones. But make still complains about not finding shaderc. I tried moving some of the directories aroung and deleting the ../build_linux directory but no such luck.

Any ideas how I can make it use the precompiled shaderrc?

I got it to compile by putting all the precompiled libraries into ../lib/linux_x86_64_glibc_228 however I was hoping for a scheme by which only the necessary precompiled libraries have to be there and it will use system ones if possible.

Also the resulting executable appears unable to detect my NVidia gpu, even though the installed copy of Blender seems to work. Ideas?

In what regard is it unable to detect your GPU?

If your GPU is not detected for Cycles rendering with CUDA/OptiX, then you probably didn’t build Blender with CUDA binaries. Refer to here for more information: Cycles GPU Binaries - Blender Developer Documentation

If your GPU is not being used for things like workbench or EEVEE, then that’s a different issue and would suggest some issue with your system in general.

In fact according to the CMakeCache CUDA is turned off. Will look into your link.
It seems it killed the ability to run Optix, even on the normal distribution of Blender when I ran it after this (which otherwise ran Cycles on the GPU), is that possible?

Any ideas if it is possible to build with some precompiled libraries and use the installed packages for others? I would also be interested in linking with my own build of USD from the Pixar repository.

not possible, its either all system libs or all precompiled, mixing them is not an option in our build scripts.

Thanks that is what I thought. I’m not clear if it is possible to use just system packages even on Ubuntu, for instance the precompiled stuff includes USD and that .py script does not try to do anything about USD so it can’t possibly install a usable copy of USD. Is this correct?

BTW make release gets CUDA. I’m guessing that it makes the build so slow (it is still running now for me) that it is worth while to turn it off to do development builds.

It may be stuck in Linking CXX static library lib/libbf_nodes_function.a or should this take a really really long time?

It finished that step, but I was getting worried my little laptop I’m compiling on was going to melt. It is normal for this to take many minutes, correct?

Compiling a large project like Blender can take a while. And when you start adding GPU binaries to Cycles, it can get longer, a lot longer depending on how many you add.

To reduce the impact of compiling GPU binaries, you can only build the binary you need. That way you’re only compiling one binary rather than 6 or something.

If you will be using the build only on your own computer, you can compile just the kernel needed for your graphics card, to speed up building. For that you need to edit CYCLES_CUDA_BINARIES_ARCH in the CMake configuration, and leave only the architecture needed for your GPU.

Source: Cycles GPU Binaries - Blender Developer Documentation

The vast majority of computers have features to stop things like this happening. You shouldn’t have to worry about your computer melting.

If you are concerned about that, you can decide to compile Blender with fewer threads. This will make compilation slower, but can typically reduce the power draw of the CPU, and thus reduce the temperature.

I’m highly doubtful compiling Blender stopped OptiX from working on builds from the Blender foundation. What may be more likely is that you were adjusting packages trying to get system libraries to work, and might of accidentally uninstalled the part of the driver that makes OptiX work.

Unfortunately I suspect you are right. That is going to be a pain to try to fix.

It might be as simple as re-installing the GPU drivers.

Looks like it is OptiX denoiser creation has failed · Issue #146 · flathub/org.blender.Blender · GitHub
I downloaded the version from and it works just fine.

The flathub version of Blender is not maintained by the Blender foundation, and as such the Blender foundation does not guarantee support in those versions of Blender.

The only officially supported versions of Blender are linked on the Blender webpage (, where you got your working build).