Left click select keymap

@jendrzych, ok, I can see how that works. Dragging an unselected object then requires two clicks instead of one I guess. It would require some deeper work to implement this beyond keymap changes, but it’s interesting to consider.

Yep - this would allow fast workin’ with just mouse/pen/whatever.
…look mom - one hand!

In left click mode, it feels counter-intuitive to right click in ‘Timeline’ and ‘Sequencer’ to drag the time cursor. Could this be the left click/drag instead?


Well, no, not in a naive way, because with left click select, left click is used for, well, selection.

However, the issue is valid, and we talked about a few ways to make scrubbing the playhead nicer with LCS:

  1. Left clicking in an empty area can set the playhead to that location
  2. Left-dragging the playhead along the bottom (or top) could move the playhead
  3. Shift-RMB dragging anywhere could serve as an alternative way to scrub the playhead, consistent with how you can always set the 3D Cursor this way in the 3D View.

To make #2 work well, we would ideally split the scrollbar away from the frame indicator groove, like so:

This way you could still use the scrollbar normally, but clicking anywhere in the groove at the top would move the playhead. This goes beyond the keymap itself, but it related due to the implications of wanting to use the same mouse button for different things.

It has the added advantage that the scrollbar could look more similar to our other scrollbars.


Left click select is broken since at least 59f0db430a9.

There’s is a significant delay. It’s especially noticeable when trying to quickly select individual faces in sequence. It’s also present in other modes including object mode.

Initially I thought it was caused by the tweak behavior of the select box tool, but the delay remains when disabling these keymaps.
Also, with the cursor tool active and with the LMB cursor placement keymap disabled, therefore allowing for selections, the delay still remains.

Switching to right click select, selections are snappy and immediate again. To me it’s too imprecise however and so not usable. I just have more control with my index finger.

I hope this will be addressed. It’s a deal breaker for me.

1 Like

@brecht How about integrate the “move” gizmo in the selection tools (box/circle/lasso)?
That would speed up the “select and move” workflow a lot when using the selection tools.
The gizmo would be manipulated with LMB as well ofc.

Blender currently (no gizmo)

Suggestion example


Please don’t, or at least give us the option to disable the gizmo again. It gets in the way and there’s no need for it in keyboard centric workflows.


@MACHIN3, in order for click to select and for drag to activate tools, select happens on left mouse button release (“click” event in the keymap) rather than press. There isn’t really a good way around that if you want both to be on the same mouse button, since you can’t detect if a drag operation is going to happen on the moment you press.


@brecht You are a live saver. That fixed it wow. I don’t care for the dragging behavior at all tbh.
Thanks, I really appreciate that!

I like having the menu instead of 3d cursor as default, however since the change I cant snap the 3d cursor to vertex the way i used to be able to. Before with snap to vertex selected if I were to click and drag over a vertex the 3d cursor would snap to the vertex. Now with the shift+click the 3d cursor stays at the location of my original click. Without the drag action I cant snap 3d cursor to vertex.

@AnyThreeWords, you can activate the cursor tool if you want to do more advanced cursor operations. It was a choice between having box select or cursor drag on LMB drag. It could be good to support Shift+RMB drag for the cursor, not sure if it can fit.

Thanks for the tip. That’s functional. It was supper convenient to be able to access that feature by clicking. Is there a hot key to access the cursor tool?

@MACHINE3 I just downloaded the most recent build to see what you were upset about. It’s bad and I don’t understand why you are happy now.
All these years I felt that Blender’s selection tools were nearly perfect (except for auto-grab), Up until now I could easily select individual vertices even when zoomed out so far that neighboring vertices were starting to visually overlap.
Auto-grab is now gone(Yeah!), but selection is now totally broken even for just a simple cube. I just did some quick testing using the same Wacom pen tablet I’ve been using with Blender since 2012. Sometimes I can select a vertex on one try but usually I have to click on a vertex several times to get the selection to register even if I click and release quickly.
I decided to keep trying to select various vertices of the default cube while counting how many times I have to click to get the selection to work and once it took eleven tries to select just a single vertex.

This change has completely broken Blender for pen tablet users. It’s as if the distance threshold changes erratically and the more I zoom in the worse it gets. Even clicking then immediately releasing directly over a vertex fails more often than not.
It’s worse than trying to select multiple material nodes with a pen tablet, that’s always been broken, I stopped trying to do that years ago.

The reason I started using Blender in 2012 is because I bought a pen tablet and after several times of Googling "3D software with best pen-tablet support " Blender kept coming up at the top of everyone’s list. That’s gone now so long as justifications for this change continue instead of it being reverted.

I hope this problem is taken seriously because Blender is now unusable for many people. Why can’t drag-selection be implemented only when the shift key is held, that works now anyways and left-click-to-select can go back to working the way it did before.
Auto-grab should definitely be optional as a user setting. That’s something that doesn’t need to be restored.
FYI, in one video, Andrew Price actually wondered out loud if it(auto-grab) was a bug. It’s a feature that becomes a bug once the scene is complex enough to cause even slight viewport lag.

@MarcClintDion, have you tried increasing the Tweak Threshold in the user preferences? Sounds like it’s too sensitive for your tablet.

@MarcClintDion Your selection issues seem a bit like Nahuel’s issues, although he is refering to pressing buttons with the tablet.

I managed to fix all my issues, by doing this: https://twitter.com/machin3io/status/1063580809234399232

I don’t really use auto grab, but it looks like you can still do it with the transform or move tools active. I personally don’t like having these active, because I don’t like seeing the gizmos. So, it’s the cursor that’s my active tool from now on.

u guys removed Action/Select events and changed the old behavior were LMB Grab/Select and RMB drags the cursor for context meun special and box select which shouldn’t be changed in my opinion it slows things down…the problem with box select that i tried to solve was with ctrl+RMB and Sub/add with Ctrl+shift/Alt works perfect.

this is how changing pivot and snapping was far superior this way, now it’s more clicks with less precision.

I’ve tried going back and forth between 3 and 1024 multiple times for the ‘Tweak Threshold’ settings. The selection behavior is identical for both.

The broken selection thing is completely fixed by changing “click” to “press” and ‘box-select’ still works exactly as before with no hint of the conflict that Brecht mentioned. Maybe that issue he mentioned above was an issue early on and someone made a change that solved it.

Also, Auto-Grab is still no longer present for click and drag and that’s beautiful. It turns out that it can be disabled. Username: Nikprodanov explains how. https://www.blender.org/forum/viewtopic.php?t=18871

I wish I knew about that years ago.

1 Like

Have you used other 3d apps? What I’m suggesting is a critical feature and very powerful, Only blender lacks it. And ofc there should be an option to hide it.
And no, I’m not a fan of “keyboard centric workflows”…

1 Like

@TheRedWaxPolice, I think you’ll want to use the “Industry Compatible” keymap when that is ready. The intent of the Blender keymap is not to try to emulate other software, but work efficient in its own way which does make use of the keyboard.