Latest Git for Windows update breaks "make update"


#1

Just a quick info for anyone building Blender under Windows.
Today there was an update to Git for Windows ( 2.19.2 ) and after I updated I couldn’t get “make update” to work properly. It just threw a WSASocket error. Google didn’t help at all. But I took a look in the changelog of Git for Windows and this looks like the cause:

Please note: Git CMD is deprecated as of this Git for Windows version. The default is to have git.exe in the PATH anyway, so there is no noticeable difference between CMD and Git CMD. It is impossible to turn off CMD’s behavior where it picks up any git.exe in the current directory, so let’s discourage the use of Git CMD. Users who dislike Git Bash should switch to Powershell instead.

Downgrading to 2.19.1 helped.


#2

Yeah that’s not it, just a bug in git, not much we can do about it also looks like it has already been fixed/reported


#3

Ah! Good to know. Thanks!


#4

Just so happens I just tried to get my Windows build working today for the first time (been working on Mac and Linux up until now). Saw the same problem. But switched from git:// to http:// and it worked for me.