Latest build fails on old MacOSX (Sierra) with to 2 errors

Hello, I opened a ticket with the details but was redirected here.
At the end of compilation, two errors appear: one about undeclared malloc and the other about call to function ‘free’ that is not visible in template def. Details in the ticket.
Thanks for having a look at this!

I just built it on macOS and didn’t have a problem.

Thanks for trying. I just tried it now too and it seems it’s been fixed already.

Actually there is an issue still. It compiles fine on recent OSX but not on my old Macbook Pro. On MacOSX Sierra 10.12.6, with XCode SDK 10.12, Blender cannot compile anymore. I guess it’s time to update this machine, that is, if Apple doesn’t prevent installing Mojave on this good old laptop…

Updating XCode solved it. You can also choose to compile with g++ if you have it with homebrew.

Did you create XCode Project? I’m having issues with “libomp.dylib” not found…libomp.dylib is present under Resources. Can’t figure out the linker settings in Xcode 10. (Blender 2.8 built successfully via CMake command-line).

That one should be now fixed.

No I didn’t create any XCode project.

I think the libomp.dylib issue is because you haven’t run “make update” recently. That’s at least what happened to me. Two weeks ago or more, OpenMP support was added for OSX.

In your terminal or iTerm in the source folder of Blender, run “make update” so that it updates the lib folder with it or worst case, remove the lib folder and run “make update” again. Then “make”.

Fresh Download and compiled successfully. It’s the optional XCODE project creation that’s giving me fits. Think it as to do with 3rd party “Framework” insertion via linking for the libomp.dylib? It’s buried in the Xcode project setup or I need a build phase script to embed/link to executable?