Lagging sculpting with over 1 milion polygons on a High-End PC

Hello :slight_smile:

As in the title I have the problem with non responsive scultping while I’m working on my T-Rex.
The brush is so delayed that I can’t sculpt, sometimes I have to wait like 5 seconds to see the effect, I tried to serach on the web how to resolve the problem but I couldn’t find anything, I will add that I’m not using any modifier and my PC specs are quite good:
-CPU Ryzen 3900 12 cores
-GPU RTX 2080 Super
-RAM 32 Gb 3600 Mhz

Please help me I’m quite newbie, I was searching how to resolve it since yesterday and still nothing :frowning:

2 Likes

Might be because of dyntopo which is currently not the best thing to use… Try disabling it and using remesh instead.

You can set the resoultion for remesh with SHIFT+R and remesh it with CRTL+R

1 Like

Unfortunately, didnt change antyhing :confused:

Weird. My system is not as beefy as yours and i can sculpt with 10mio at least but without dyntopo. Its hard to guess whats causing it without the file. Did you enabled the thread option in the sculpt menu?

1 Like

Where Can I find the thread option? Here you go the file :slight_smile:

Could you send me something yours over 2 mln polygons so at least I will know that this isnt the problem of my scene.

Yes, it is active, the thread option.

Thanks for the file. It because of the armature modifer. Delete (Or hide it with the screen icon that solves it too) it and it runs like a champion but i still need to figure out why the modifer is causing it…

EDIT: I have no idea why, maybe a bug but normally you would rig it after sculpting.

One more thing is that the model is not in the origin which can bring problems. Like mirroring is harder to do because you need a custom mirror point and so.

Enjoy sculpting.

1 Like

Thanks, you are a master! The problem is solved, but is it normal that while trying to use dyntopo there are still lags?

Sadly at the moment yes. The plan is to improve it and at the moment its better to use remesh. A value of 0.02 will be okay. Then go lower for more details. At the beginning you lose a bit of detail though its not optimal for realistic stuff more for stylized… Maybe someone else can give here more tips but that is my current workflow.
The problem with that is for example the fingers ( And that one side nail at the foot) of the dino will fuse together. So maybe stretch them a big more apart or do them later…
To spread them apart you can use the pose brush and under advanced activate Topology option.

And for the armature modifier that could be a bug since it says it not supported in dyntopo and should automatically deactivate itself…

1 Like

What version of Blender are you using?

He is on version 2.83.1. You can see it in the bottom right corner of the screenshot he made.

1 Like

to better understand why dyntopo is slower, here is pablos talk from blender conference


highly recommended
2 Likes

@DarkKnight So basically the only thing I can do now for don’t destroy my sculpt work is to use a remesh and sculpt while the modifier is ON? :slight_smile:

No, the modifier should be off because otherwise the performance will be bad. Its just the armature of the tongue and like i said i am not sure why blender is not doing it automatically. There is also an option in sculpt mode beside the threaded one which says something like use deform only. Maybe this can help too.

For the sculpting part. Dyntopo has also a detail flood fill that is not that destructive than the remesh. I would still recommend the remesh method since with that you work on the whole body and not detail on one part of the mesh. I would have linked a tutorial but currently there is no video about that workflow i could find… Maybe the character creation course on blender cloud can help.