I had to reinstall ubuntu again, and I can't get my blender 2.8 to build properly again


#1

I think I have some libraries messed up, or not installed.
I’ve run the install_deps.sh script, and i believe it says that everything is okay, but when i build blender i get this message in the end, almost at 100%

Scanning dependencies of target blender
make[3]: *** No rule to make target ‘/usr/lib/llvm-6.0/lib/libLLVM-6.0.0.so’, needed by ‘bin/blender’. Stop.
make[3]: *** Waiting for unfinished jobs…
[100%] Building C object source/creator/CMakeFiles/blender.dir/buildinfo.c.o
make[2]: *** [CMakeFiles/Makefile2:7908: source/creator/CMakeFiles/blender.dir/all] Error 2
make[1]: *** [Makefile:163: all] Error 2
make: *** [GNUmakefile:149: all] Error 2

I get that it’s having problems with the libLLVM, but i have no idea about how to fix it…
I also have a problem running the previous build i made before i reinstalled ubuntu, something about jemalloc.so.1 not being there even though i had the latest one installed… I’m on Ubuntu 18.04.

Is there someone that has a little time to help me out? I would be most happy.


#2

It actually does seem like i have libLLVM installed, but i have a different version… How do i make it use the updated version when I compile? I have libLLVM-6.0.1.so instead of libLLVM-6.0.0.so


#3

Hello,

I already had a similar problem few time ago. I resolved it by manually modifying the “CMakeCache.txt” file in the “build_linux” directory.
Take a look at this file. Check if all the paths relative to the LLVM lib are present and correct.

Here are the paths from my “CMakeCache.txt” file relative to the LLVM lib if that can help you. I’m on Ubuntu 18.04.

//Path to a program.
LLVM_CONFIG:FILEPATH=/usr/bin/llvm-config-6.0

//Path to the LLVM library path
LLVM_LIBPATH:PATH=/usr/lib/llvm-6.0/lib

//Path to a library.
LLVM_LIBRARY:FILEPATH=/usr/lib/x86_64-linux-gnu/libLLVM-6.0.so

//Path to the LLVM installation
LLVM_ROOT_DIR:PATH=/usr/lib/llvm-6.0

//Link with LLVM static libraries
LLVM_STATIC:BOOL=OFF

//No help, variable specified on the command line.
LLVM_VERSION:UNINITIALIZED=6.0

Hope it can help you.


#4

Are you perhaps using an existing target build directory from before the Ubuntu re-install/upgrade? You might just try renaming the target build directory temporarily and thus the build will have to re-create it and re-configure the build environment and it may automagically adapt to your current environment.


#5

Did you run the install_deps.sh script after reinstalling Ubuntu?


#6

Actually, this worked. :slight_smile: When i checked the file, it said that it couldn’t find those, so i pasted in the exact thing you have written here… worked like a charm! Thank you very much.

Thanks for the other suggestions too. :slight_smile:


#7

I was actually doing that as well… I reainstalled ubuntu again after last time, and the error i got when trying to start blender after compile went away.

@RainerTrummer, yup I did that too… :slight_smile: but all is good now.