I can't load wav or mp3 in the VSE in my build and can't find the problem, help please!

Hi there.

I tested with today’s buid from the buildbot and everything loads perfectly, but in my build I get a message saying me that the MP3 or the WAV file I’m trying to load cannot be loaded, I’m not sure why, I enabled eveerything I can think of in the Cmake, so I’m a bit lost.

What can be the problem?

Cheers and thanks!

BTW I’m building in Linux, but I’m not sure if that matters in this case.
Also there is no build error and there is no other error when I try to load the MP3 or WAV, just that the file cannot be loaded

It may not be Blender itself, but one of its libraries that was not built with support for certain file formats. Possibly libsndfile or ffmpeg.

But it’s weird that I cannot load any sound file, and precisely WAV or MP3, two of the most common files, it’s weird.
The deps are automatically done with Make deps, so I think it should be fine.
Talking with @LazyDodo I tried and I found a problem with LibSndFile:


The plugin was not being build, and I think the problem is there, I tried to solve it, but I’m not being able, if you have any suggestion it will be very welcome :slight_smile:


I’d probably take a quick peek in the libs dir and validate libsndfile actually build successfully.