Developer Forum

How to build Blender for Raspberry Pi 4 ARM64?

Good day, I am trying to build Blender 2.79 for the Raspberry Pi 4B 4GB ram running Ubuntu Mate 22.04.

It is actually not possible to use the current Blender version on the Ubuntu repositories since it is on version 3.0 that uses OpenGL version above 3.1 which is not supported by the Raspberry Pi Video Core VI. It is possible to run Blender forcing the override MESA_GL_VERSION_OVERRIDE=3.3 Blender runs, but graphically, it’s not very usable, having a completely black cube, you can’t see the polygons edges.

There is not either a Snap, Flatpak or AppImage version for Arm64.

I also tried running Blender 2.79b that supports OpenGL 3.1 through the Box64 userspace, but I got into errors that lead to a segmentation fault aborting the program execution.

Tho I don’t plan to use the Blender on the Raspberry Pi for production enviroment (like texturing, lighting, rendering). I’d like to use it to do basic tutorials from CG Cookie like modelling and rigging a basic cartoon character.

So I downloaded the source code for 2.79b, but when I run the make file, it always got into an error regarding SSE function, which ARM proccessors doesn’t support. I supposse I need to delete all the orders showing " -MSSE" in the file CMakeLists, but the problem is there are too many CMakeLists in different locations of the source code.

Pointers about workarounds for this will be thanked, since I have not found build instructions for buliding Blender for this ARM64 platform

There are no build instructions for this, it’s not an officially supported platform. We do fix Arm64 build issues as they are reported, but 2.79 is no longer maintained.

I would generally expect 2.79 to be buildable on Arm64 though, as some Linux distributions have done this. Maybe it only requires a minor configuration or code tweak to get past the SSE issue, but it’s hard to tell without knowing the exact error.

2 Likes

You can install this Debian blender_2.79.b+dfsg0-7+deb10u1_amd64.deb

This is the direct link http://ftp.de.debian.org/debian/pool/main/b/blender/blender_2.79.b+dfsg0-7+deb10u1_amd64.deb

Greetings

2 Likes

Thanks for your answer.
That version doesn’t work on the Raspberry Pi, it is compiled for AMD64 and the Raspberry Pi processor architecture is ARM

1 Like

Good evening, thanks for your anwer.
Analizing the compilation steps tutorial, I noticed Blender 2.79b source code doesn’t include precompiled libraries / dependencies. I went for the install_deps.sh script located in /home/[user_name]/blender-2.79b/build_files/build_environment and ran the script on the Raspberry Pi, with the following outcome:

  • numpy-1.10.1 and python-3.5.3 compiled successfuly.

  • OpenColorIO exited with error “unknown command -msse”. I could edit its CMakeLists.txt commenting all the commands related to SSE, ran it alone (without ,/install_deps.sh) and compiled successfuly.

  • I ran again ./install_deps.sh with option ‘–skip-ocio’, but then it exited with error for OpenImageIO compilation, I attach file with the terminal output named “OIIO-error-log.txt”

  • I ran again ./install_deps.sh with option ‘–skip-ocio --skip-oiio’, but it exited again with compilation error for LLVM. I attach the file named “LLVM-error-log”

  • I gave it another try to ./install_deps.sh with options ‘–skip-ocio --skip-oiio --skip-llvm’, but now it exited with compilation error for OpenSubDiv, I attach file “opensubdiv-error-log.txt”

At that point I gave up, eventhough I tracked the error lines in the compile file, I am not a programmer and I didn’t konw what to do to fix the errors mentioned in the outputs.

Is there a way to get precompiled libraries / dependencies for Blender2.79b source code? In the source code download page ‘https:// download[dot]blender[dot]org/source/’ the option “with libraries” is only available for Blender source from 2.83 and up and I don’t think the precompiled libraries mentioned in the compiling tutorial will help me cause they are intended for CentOS not Ubuntu.
Thanks for your attention.
P.S. Being a new member, the system doesn.t let me attach files, so I will share them with my Dropbox:
‘https:// www[dot]dropbox[dot]com/s/20led6p0w51gsti/LLVM-error-log.txt’
https://www.dropbox.com/s/79cgq2swyce22pm/OIIO-error-log.txt
https://www.dropbox.com/s/r3tk1soy2qt7mqd/opensubdiv-error-log.txt

There are no precompiled libraries for rpi as it is not a supported platform for us, the 2.83 tarball will also not contain them (or any, it’s just the sources we use for our precompiled libraries for other platforms)

The link from @PaoloFurani was to an amd64 package, but that same folder does also contain arm64 packages:
http://ftp.de.debian.org/debian/pool/main/b/blender/

1 Like

direct link to the ftp package for ARM Blender_2.79_arm64.deb

Thanks a lot for the link, unfortunately, it doesn’t install on Ubuntu Mate 22.04 cause the dependencies needed can’t be solved without breaking the dependency tree of the OS.

1 Like

I found a less elegant solution to running Blender 2.79 on the Raspberry Pi. Using a spare SD card, at least 8GB size, then downloading and flashing on it the ISO image for Raspberry Pi OS Legacy that comes with Debian 10 (Buster) that has Blender 2.79 in its software repositories. Then booting on this SD card and installing Blender 2.79.

Link to download:
https://www.raspberrypi.com/software/operating-systems/

Section “Raspberry Pi OS (Legacy)”

2 Likes

Ok, so you can get it run, but you have to trample over a load of dependencies, them fix them post install. There are around 80 packages required of appropriate versions that I can list (in an Approx Order to install!)

I’ve successfully managed this on RaspberryPi OS, 32 and 64Bit. Once installed you can hold the (blender and blender-data) package and fix the dependency mess you’ve made.

This will also works for Armbian and probably other Debian based Distros for Arm64. I did this last night for my Orange Pi5. Took around 3 hours, but works.

2 Likes